Remove grey bar above footer that is not showing in page builder

Hello,

On all of my pages there is a grey bar above the footer. The row is not showing in page builder. I think I have tried everything. Can somebody please help me remove this?

Thanks so much.

Hello there,

Please share the link to the page in question, so I can take a look.

Regards,
Kharis

Hi,

Thanks for your reply. http://www.niveau-een.nl

Regards,
Sheryline

Hello there,

Please leave empty the footer widgets areas that can be managed from Appearance > Widgets in your site dashboard.

Regards,
Kharis

Hi,

The footer widget area was already empty.

It’s gone! I didn’t change anything. It must have been a bug (or whatever you call that) or something because all my setting are still the same.

Thanks for watching with me though!

Kind regards,
Sheryline

Hello Sheryline,

Please check the main theme’s footer.php file through Appearance > Editor. Does it look like this?

Regards,
Kharis

Hi,

Yes, it is the same except for the “Proudly powered by…” part.

Regards,
Sheryline

Hello there,

What will happen if you reinstall the fresh one of Sydney?

Regards,
Kharis

Hi,

I made a child theme. So all my settings will probably be gone, I think. But the grey bar is already gone. I haven’t changed the footer.php, the footer widget area was empty and there was no row in page builder. Do you know what it might have been? For maybe in the future.

If not, I’m gonna leave at this. I’m already happy that’s gone. :slight_smile:

Regards,
Sheryline

Hello Sheryline,

> I made a child theme. So all my settings will probably be gone, I think.

The modifications you’ve done through child theme won’t be gone as long as it’s still active. You’ll only need to override the main theme’s files with the fresh ones. If you’re not sure, you would need to create a staging/development site.

The problem actually resides in these lines in the footer.php file.


<?php if ( is_active_sidebar( 'footer-1' ) ) : ?>
	<?php get_sidebar('footer'); ?>
<?php endif; ?>

The grey above the footer won’t present if there is no widget be found either in Footer 1, Footer 2, or Footer 3 in the Appearance > Widgets.

Regards,
Kharis

Hi Kharis,

So I should remove those lines?

I did what you said about overriding the main theme’s files but now there is a white area underneath the footer just on one page www.niveau-een.nl/coaching/ I checked the forum on this topic but none of the codes worked…

Hello there,

It happens as the content is very short. You should define minimum height to the content area which can be achieved by adding this CSS code into Appearance > Customize > Additional CSS in your site dashboard.


.page-wrap {
  min-height: calc(100vh - 174px);
  min-height: -moz-calc(100vh - 174px);
  min-height: -webkit-calc(100vh - 174px);
}

Regards,
Kharis

Hai Khatis,

The code worked perfectly! Thanks so much for all your help.

Kind regards,
Sheryline

You’re welcome and best wishes!