Rectangle instead of three line menu for mobile after updating FontAwesome


#1

Hello.

I am setting up one website with Sydney and I updated FontAwesome to the newset version, because I needed some icons for the services that didn’t appear in the version that came with the theme.

My problem is that after I included one function in the functions.php of the child theme, the icons I needed appeared but the icon of the mobile menu disappeared. Instead, the only thing I can see is a rectangle. I am able to move it, or to change its colour, but the symbol doesn’t seem to come back.

Is there any easy way to fix this? I know that if there isn’t, I could make the icons of the services as an image, and go back to the old FontAwesome, but I think that there should be a way to make the three line menu come back…

By the way, this is the website:

https://neverlandkids.es/


#2

Hello there,

To adjust new Font Awesome code on the mobile menu button, try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .btn-menu:before {
      font-family: "Font Awesome 5 Free" !important;
      content: "\f0c9" !important;
    }

Regards,
Kharis


#3

Hello! Thanks for your answer!

I’ve tried this code but it doesn’t work; I’ve double checked that I copied it well, and I copied it into Appearance>Customize>Additional CSS…

I had thought this should work, but I’ll try to keep searching :frowning:

Thanks anyway for your effort.

Kind regards,


#4

Hello there,

Try adding this CSS code to Additional CSS:

    .btn-menu:before {
      display: none;
    }

then do the below steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box
    ;(function($) {

      $('.btn-menu').html('<i class="fas fa-bars"></i>');

    })(jQuery);
  1. Update

Regards,
Kharis


#5

You might need to flush the applied site caching before reloading your site. Otherwise, it won’t load the new code additions’ effect.

https://codex.wordpress.org/I_Make_Changes_and_Nothing_Happens

Regards,
Kharis


#6

Hi! Thanks for your fast answer!

I did just now waht you wrote, and this time the menu is back. So problem solved!

So thanks for your help again! :slight_smile:

Regards,

Patricia


#7

Awesome Patricia!

Glad to have an opportunity to assist you. Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis


#8