Recenti Post Type F - problem

Dear friends, I am using NewsAnchorPro theme. In the homepage top widget I am using a ‘recent Post Type F’ but the first of the four images (near the left border of my display) is NOT shown. It’s not a problem pf content, 'cause I have already tried in changing the post. All posts in this position work (or better, do not work) in the same way. Any idea how to fix this problem? Thank you very much for your help! Ciao, lorenzo

Hi,

Thank you for reporting this, seems like there are missing code on the widget script.
Please wait the next release of the theme or you can also fix the issue using child theme, here is the steps:

  1. create a child theme and activate it.

  2. duplicate “widgets/recent-posts-f.php” file from the parent theme to the child theme.

  3. open recent-posts-f.php file on the child theme and change this line:
    <?php if ( has_post_thumbnail('newsanchor-medium-thumb') ) : ?>
    to:
    <?php if ( has_post_thumbnail() ) : ?>
    http://prntscr.com/azmh6t

  4. open functions.php file on the child theme and add this line:
    require get_template_directory() . '-child/widgets/recent-posts-f.php';

  5. open functions.php file on the parent theme and change this line:
    require get_template_directory() . "/widgets/recent-posts-f.php";
    to:
    // require get_template_directory() . "/widgets/recent-posts-f.php";

That’s it. Let see how it goes…

When is a new release expected?

Hi there, thank you for your kind reply. When next release will be available? Thanks everybody!

HI Awan, thank you for your help with your previous answer. I would prefer to have an update of your theme, of a fixing of the parent theme. It’s a paid theme, so I think should work properly in all those things. Could you please help me (and other people) in this direction. I could open an admin account in my website to make stuffs easier.

Thank you for your understanding,
Ciao,
Lorenzo

Hi guys,

Really sorry about this issue and the time it took to fix it, I was just made aware of it now. I’ve updated the theme and you should have a notice to update. Any issues now or in the future feel free to email me directly at vlad[at]athemes.com

Thanks.

Vlad, the fix in your update works very well for me - THANKS!