Recent Posts section showing on every page

Dear support team,

Every time I create a new page to redirect people from a button to a new page. There’s this section on the right side of the page with “Recent Posts” – I think this had to do with blogposts?

I don’t want this to show up on any of the above mentioned pages. How can I make sure this will be deleted instead of showing up on every single page? Is this standardised when creating a new page?

Thank you.
Marcel

Hello there,

The sidebar area which contains recent posts widget always appears on the default page template. If you want to remove it, you can use either Full width or Front Page template. This template options is available in the Page Attributes box in the page editing panel. To hide the sidebar area on default template, you can add this CSS code into Appearance > Customize > Additional CSS in your site dashboard.


.page #secondary {
  display: none;
}

To force the content area to be full width, add this code:


.page #primary {
  width: 100%;
}

I hope this reply helps.

Regards,
Kharis

Hi Kharis,

Perfect solution.

Thanks a bunch.

Cheers,
Marcel

You’re welcome, Marcel!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis