Random edit button at bottom of page

Hello,

How do I get rid of this random edit button at the bottom of the page?
https://nimbus.everhelper.me/client/notes/share/255589/RHahhxInO1CsAMKCntO5FIvEziFSh9UP/

Hi JPMI1.

You need to.

1.Open Editor under appearance
2.Go to content-page.php
3.Delete everything in it and replace with all of this. (Look underneath)

Hope it helps.

<?php
/**

  • The template used for displaying page content in page.php
  • @package Sydney
    */
    ?>

<article id=“post-<?php the_ID(); ?>” <?php post_class(); ?>>
<header class=“entry-header”>
<?php the_title( ‘<h1 class=“title-post”>’, ‘</h1>’ ); ?>
</header><!-- .entry-header -->

&lt;div class="entry-content"&gt;
	&lt;?php the_content(); ?&gt;
	&lt;?php
		wp_link_pages( array(
			'before' =&gt; '&lt;div class="page-links"&gt;' . __( 'Pages:', 'sydney' ),
			'after'  =&gt; '&lt;/div&gt;',
		) );
	?&gt;

Parse error: syntax error, unexpected ‘class’ (T_CLASS) in /home/jpmi1/public_html/bitlunches.org/wp-content/themes/intro/content-page.php on line 11

Any help?

@jpmi1 I think there is something missed with the code in above and the code is for Sydney theme. please undo your changes or you can try to use this code:

<?php
/**
 * The template used for displaying page content in page.php
 *
 * @package Intro
 */
?>

<article id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
	<header class="entry-header">
		<?php the_title( '<h1 class="entry-title">', '</h1>' ); ?>
	</header><!-- .entry-header -->

	<div class="entry-content">
		<?php the_content(); ?>
		<?php
			wp_link_pages( array(
				'before' => '<div class="page-links">' . __( 'Pages:', 'intro' ),
				'after'  => '</div>',
			) );
		?>
	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<?php edit_post_link( __( 'Edit', 'intro' ), '<span class="edit-link">', '</span>' ); ?>
	</footer><!-- .entry-footer -->
</article><!-- #post-## -->

Thanks still have the edit button but the site works now

from the code above, you can try to remove this line <?php edit_post_link( __( 'Edit', 'intro' ), '<span class="edit-link">', '</span>' ); ?>

Hi, all, I just took Christian’s advice and changed what’s in the content-page.php and now ALL my site’s content is missing.
I don’t have a Restore checkbox in my Screen Options on the dashboard for some reason
How can I undo the changes or go back to a previous version???

Hi @letters

Did you change the file using theme editor? it’s too risk if you modify the file directly from there because if you put the wrong code, your site will not display anything and there is no option to undo the change!

All you need to do is you have to open the file using FTP or using File manager from your cpanel then putting back your previous code to the file.

Hey, @Awan
Yes, I had done that originally as per the posts above and it deleted everything. Luckily I noticed an Update was available on the Sydney theme and once I did the update, it all came back. *giant sigh of relief!!
I’ll do it via the cpanel this time and hope that it goes better! Thanks :slight_smile:

I see, good luck :slight_smile: