Projects NOT FOUND Error 404


#1

Hi Vlad,
I’m having troubles with Services and Projects sections because when I click on a single “projects post” appears a Server error: HTTP Error 404.0 - Not Found

I think it’s a Types problem. I’ve installed everything following your instructions and I’m not comfortable with Types problems.

Thank you in advice!
Lucia



#2

It would appear that your website is not working?
404 errors with custom post types can usually be solved by re-saving your permalinks, without making any changes, just re-save.


#3

Thank you Vlad! I searched on web and I found a solution!! I re-saved the permalink and I created a new file web.config with the following code. It works!

<configuration>
<system.webServer>
<rewrite>
<rules>
<rule name=“wordpress” patternSyntax=“Wildcard”>
<match url="*" />
<conditions>
<add input="{REQUEST_FILENAME}" matchType=“IsFile” negate=“true” />
<add input="{REQUEST_FILENAME}" matchType=“IsDirectory” negate=“true” />
</conditions>
<action type=“Rewrite” url=“index.php” />
</rule>
</rules>
</rewrite>
</system.webServer>
</configuration>


#4

I have the same problem here. When you say “re-save” the post does it mean just click Update or what ? Because I tried but it doesn’t work. And how did you created this file ?
Really sorry for bothering you but it’s a real mess with this permalinks not working… I’ll appreciate your help. Thank you.


#5

It’s not really a mess, sometimes Wordpress does this.

I didn’t say re-save the post, I said re-save the permalinks. Please go to Settings > Permalinks.
I assume your issue is with the custom post types.

Let me know how it goes.


#6

Yes it works ! I just click SAVE without doing any changes and it worked. Thank you so much !
Cheers