Problems with services

Hi.

For our webpage, www.twopack.no, I’ve made all the services, but when trying to add the Services Type B widget to our frontpage, things go wrong. I add the widget, and the preview looks fine, but when saving changes, the frontpage (in the editor) shows one of the services pages, as the only content. So, the entire frontpage gets wiped, and replaced with a service.

Any idea what goes wrong, and how to fix this?

Hello there,

By default visiting www.twopack.no/services will display list of your services. It’ll return not found if the services slug has changed. Let me know if you have changed it.

Regards,
Kharis

Hi!

Yes, I’ve changed the slug, but that’s not the problem here. What happens is that, when I add the services widget to our frontpage, the entire content of the frontpage is replaced by one of the services. So, the entire frontpage is lost…

Hello there,

Your WordPress might not be able to recognize the new slug name applied to the existing one. You should have to flush the permalinks structure by going to Settings > Permalinks; and just hit the save button.

Regards,
Kharis

Hi!

Tried this, but with the same result. Our slug www.twopack.no/trubadurtjenester seems to work, even though the layout is’n too nice yet, but… Still, when adding the widget, and saving, the frontpage content is replaced by a service, so our complete page is messed up. Any ideas on what to try next, to get this fixed?

Just saw that both the frontpage, and a testpage that I use, are both replaced by the service with the slug /trubadurtjenester/duo-til-firmafest

Hello there,

Try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .post-type-archive-services .panel-layout {
      display: none;
    }

Doesn’t it fix the problem?

Regards,
Kharis

Still doesn’t work…

What I see, when I backtrack to the previous revision, to get the correct frontpage, I see that the page id has been changed. So, the page id for the frontpage is set to the id of the service, that’s being set as the frontpage, when this occurs… Also, everytime I add the widget to the frontpage and hit save, I’m being sent into the editor for the service…

Hello there,

Probably you should create a new separate page with different title, so you’ll get different permalink. I guess there’s permalinks conflicts.

Regards,
Kharis

The page titles are completele different. The frontpage and the service page doesn’t have the same permalink…

Any other ideas on what might be causing this?

Here you’ll find screenshots for the permalinks.

Also I added screenshots from my testpage, which has the same errors, when I add the services widget to our frontpage. I took screenshots of the differences, only…

Frontpage

Hello there,

Please try flushing the permalink structure by going to Settings > Permalinks; and just hit the save button. If it doesn’t help, mind sharing the admin login and allow me checking it directly?

Regards,
Kharis

Hi!

Have you had the chance to look at this one? Sent you a PM with login credentials to the site. :slight_smile: