Problems with last update


#1

Hello,

The last areview theme update is incomplete, code is missing.

  1. featured image not showing up on all pages:
    To fix this, you have to go to the file “content-page.php” and add this line of code between </header><!-- .entry-header --> and <div class=“entry-content”> :
    <?php if ( has_post_thumbnail() ) : ?>
    <div class=“single-thumb no-review-thumb”>
    <?php the_post_thumbnail(‘single-thumb’); ?>
    </div>
    <?php endif; ?>

  2. Carousel in not showing
    I couldn’t find how to fix this yet, is it a problem of mine or the theme incomplete again?

I don’t understand why the update is not tested before being released to the public…

(site: jeux-bitcoin.com)


#2

how to edit a topic?


#3

Hello @reviw

  1. content-page.php file wasn’t changed on update, are you sure that update caused your first problem?

  2. Can you please provide more details about your carousel issue?

  3. I’m not sure if users with participant role can edit old posts.

Kind Regards, Roman.


#4

Hello Roman,

  1. Ok. I wanted to edit the topic because it was me that added the code so that is why the update erased my code. So no problem.
  2. The only problem now is the carousel not displaying at all on desktop and mobile: http://jeux-bitcoin.com.
    A Parser-blocking, cross-origin script, https://ajax.cloudflare.com/cdn-cgi/nexp/dok3v=f2befc48d1/cloudflare.min.js, is invoked via document.write. This may be blocked by the browser if the device has poor network connectivity. See https://www.chromestatus.com/feature/5718547946799104 for more details.
    Maybe it is my connectivity, the carousel was working fine before the theme update. Or maybe it’s cloudflare’s rocket loader.
    Can you see the carousel or is it just me?
    Thanks.

#5

Hello @reviw

I’m not sure why your carousel doesn’t work anymore. Did you add posts by checking a checkbox in post editing section?

Kind Regards, Roman.


#6

Hello Roman,

Yes I checked/unchecked, disabled plugins one by one, cloudflare on/off, etc. The carousel is not showing up. It was just after the update that it disappeared, same on other sites of mine with areview theme (also pros and cons not showing in reviews)
Do you know what files where modified in the last update? maybe bootstrap, and carousel files?
Thanks.


#7

new question: in which file exactly is the homepage template? Maybe the code for getting the carousel is simply missing.
thanks


#8

Hello @reviw,

Did you use this solution before update?

Do your posts have featured images? In which mode your website currently is (which code did you import into Custom Field Suite plugin), product review mode, movie review mode, or game review mode?

Kind Regards, Roman.


#9

Hello Roman,

No I didn’t use this solution before update.
I removed/reinstalled featured images in post, check/unchecked the box “display carousel”, tryed with different number of posts in carousel, different categories. Carousel is not showing up on all browsers and all devices.
CFS plugin yes already checked: product review mode, resetted, reimported code…
Have no idea what the problem is. Verified the header.php file and the carousel code is not missing:
<?php if ( is_home() && get_theme_mod(‘carousel_display’) ) : ?>
<?php echo areview_carousel_template(); ?>
<?php endif; ?>

Kind Regards


#10

Hello @reviw,

I have just tried to enable carousel on my localhost clean install (product review mode) and it worked. Can you please try to reinstall the theme? But please make a full site backup first.

Kind Regards, Roman.


#11

Hello @Roman,

I reinstalled the theme. Everything is working except the carousel.
Regards.


#12

Hello @reviw,

It looks like this issue requires close inspection, this goes beyond our support policy. As an option, you can find a reputable freelancer on Upwork for this kind of service.

Kind Regards, Roman.


#13

Hello @Roman.

Ok I will contact them.
Do you know where I can get the previous theme version? I d’like to reinstall it, just to see if it works.
Thank you.


#14

Sure, here is the download link:
https://downloads.wordpress.org/theme/areview.1.01.zip

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.


#15

I found the problem but not solved yet. When I go to ‘Customizing’ > ‘static front page’, carousel is showing up for ‘Your latest posts’ but not showing up with ‘A static page’> ‘front page’ selected (whatever front page I select). That’s why the carousel did not display on my homepage. Best Regards.


#16

Hello @Roman,

Carousel is working now! I replaced ‘is_home()’ by ‘is_front_page()’ in header.php and carousel.php files.

Kind Regards.


#17

Hello @reviw,

Thank you for pointing it out! I have already added this issue to our list.

Kind Regards, Roman.


#18

You are welcome @Roman,
thank you for the support.