Problem with map not displaying

On my site http://informatykgorzow.pl/ I have a problem with map o the botom of the main page not displaying. When I log in to editor to edit map module it does not recognize my city: Gorzów Wielkopolski - is it a problem with diactrical marks? But i tried to enter it without using them (like typing o instead of ó) and still nothing, i tried to enter Gorzow alone but it did not help. It’s a fairly big polish ciy so i do not know why it does not work. When i enter for example Warsaw it works. Is it possible to resolve this, or maybe I am doing something wrong? Thanks in advance.

Hello there,

I would like to apologize in advance for the inconvenience.

For some reason, Google now requires a JavaScript API key/authentication to use the Google Map service. To temporary fix it, please edit the following files in the child theme mode:

  • header-rev.php
  • header-slider.php
  • header-video.php
  • header.php

Replace the following line:


maps.google.com/maps/api/js?sensor=false

with:


maps.google.com/maps/api/js?sensor=false&key=YOUR_API_KEY

Replace YOUR_API_KEY with your Google API key. You can obtain it here https://developers.google.com/maps/documentation/javascript/get-api-key

The permanent fix would come in the next version update.

Regards,
Kharis

Is this in the new update?

Hello there,

In the latest version, the map API key can be set through Appearance > West Pro options > Google Maps.

Regards,
Kharis

Will there be a similar fix to the Sydney Theme? I am at a loss. I have finally managed to get maps to show up on my events pages, but the widget on the left side of the footer is supposed to display a map. It is a Jetpack Contact Info widget within a page builder layout. I have my API key set up in the Google Console with credentials and have enabled the Google Maps Geocoding API, Google Maps JavaScript API, Google Maps Embed API, Google Static Maps API, and Google Places API Web Service.

I also came across this thread where other Sydney theme users are experiencing the exact same issues and getting the same messages that I am with the Jetpack contact info widget. https://wordpress.org/support/topic/maps-can-not-plot-this-address/ I have tried all of the advice they gave here without any luck.

My site it www.stantononline.com If I need to start a new thread, just let me know. Thanks.

Hello there,

Please review once again the Jetpack’s Contact Info widget.

Regards,
Kharis

Thanks, That was actually the first page I visited when I initially had trouble. I followed all those steps exactly but it did not work.

Hello there,

So sorry for the delay.

Please share the working login credentials to your site’s admin area to kharisblank@gmail.com to allow me inspecting it directly. Don’t forget to include the link to this thread in your email body, so I can easily identify the related support query made by you.

Regards,
Kharis

Hi Kharis,

Thanks for your reply and willingness to help!

In the meanwhile, I believe I have stumbled upon a solution, so I will pass it along for others out there who may be struggling with this:

After a lot of trial and error and what seemed to be a more intricate procedure than necessary, I have a working map in my Jetpack Contact widget on my sydney theme website stantononline.com.
There is indeed a trick to getting this to work once that error comes up.

Step 1. The API key needs to be removed from the widget and saved as is. (The site will load with an error message about API where the map should be now.)
Step 2. The restrictions need to be removed from the key in the Google API Console and set to “none” and saved.
Step 3. Then add the API key back into the widget and save. (Hopefully, you will see a map now on the front end.)
Step 4. Once the widget is working, then go back and enter restrictions as follows .example.com/ just as they provide in their example. (I used .stantononline.com/)
Step 5. Cross your fingers and hope it stays working!

Note: Anytime I went back and modified the widget in any way, I had to repeat this ENTIRE process all over to keep get the widget working again.

I know how helpful all these forums have been to me as an amateur and am just hoping to pay it forward.

Great! You figured it out. Thank you very much for sharing. We really appreciate it.

Regards,
Kharis