Problem with creating blog page

Hello

I really love Perth Theme but I have little problem:
when I edit my menu I can’t see all my pages and add them “normally” to menu. In the bookmark “See all” there is only my home page and one page without the title. I added already other pages to menu by searching them by names… but I don’t know how to create Blog Page because I can’t choose any page except one page (without title). I’m not sure if I explained it well…

Thank you in advance.

Paulina

Dear Paulina,

Thank you for getting in touch here.

Try to do the following:

  1. Create a new blank page (Dashboard > Pages > Add New). Just enter the title, e.g. Blog. then plublish
  2. Go to Settings > Reading > Front page displays > select “A static page (select below)” > select your front page and select “Blog” as your posts page
  3. Save changes
  4. Go to Appearance > Menus > put the “Blog” page to your menu item

Regards,
Kharis

Hey Kharis you are doing a great job. I also have a query. Whenever i create a page and put it in my menu, the page gives the error “page not found”. Please help me with this. I have tried to reinstall the theme but again it is the same. I want to make other pages as well. but every page giving the same error and i think this thing is related to the plugin “toolset”. and this plugin is compulsory for the theme. What should i do. Help me out.
Thanx in advance

Hello there,

Generally, this such kind of error can be resolved by flushing permalink. From your dashboard, navigate to Settings > Permalinks > just hit the “Save Changes” button. If it doesn’t help, you should see the .htaccess file in your root folder where you install the WordPress files. Check it whether it looks like this:


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

See the WordPress codex.

Regards,
Kharis