Problem using Polylang, translated front page won't load

Hi there, I’m having some problems using Sydney Pro. I’ve used this theme other times and it never gave me problem but this time is giving me some problems.

My website is www.algarveboxcup.com

First I made all the website in English and it worked fine but I can’t use any plugin for translation that it starts bugging.

First of all I don’t know why but the main problem right now is that when I select the front page in Portuguese it won’t load. It loads every other page other then the Front page in Portuguese. I’m using Polylang to set the languages and setting only English and Portuguese.

I have installed Polylang, I have seen all the information you gave here https://athemes.com/using-polylang-in-some-of-our-themes/ , I have tried desativating all the plugins multiple times, and have tried to use Polylang with Lingotek ativated and destivated. I have also tried qTranslate-X to see if it was a problem with the plugin but it still bugged.

I find it strange because I have already used Polylang on other websites including some with Sydney Pro theme and it worked just fine.

Another bug that happens me is that when I edit the content on a certain language on Page builder it changes the widget on both languages, when I revert to wordpress editor I can change it in both languages but then can never come back to the Page Builder editor again, I find it really strange because again I have already used Polylang with Sydney and Page Builder by Site Origin and it always worked fine.

Hope you can help me, thanks.

Hello,

  1. It looks like your Sponsors section JS snippet is causing the issue, please try to remove it and see if it helps.

  2. Please create a new topic for your second issue to keep forum in good order and make it easier to help you.

Kind Regards, Roman.

Solved my main problem from now! Thanks a lot!

Great! You are welcome :slight_smile:

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.