Preloader not disappearing on mobile

Hi Since a couple of days the preloaded doesn’t disappear on mobile devices. It does on normal browsers.

I disabled all new plugins but that didn’t change it. Can you please help me find the issue?

Edit: The issue is on IOS 8 with safari.

I checked on an 5s and I see it also. Though it works on our demo site so the issue must be related to your site. I’ll try to debug but meanwhile think of any other changes you might have made.

I have traced the problem back to the use of the audio shortcode. If you reload the page you now see it load and the tags i am using for audio (with some spaces)

Do you know if this is fixable within the theme? Audio is a core function of wordpress as i understand it. Perhaps other users have this issue also.

You could disable the preloader on small screens as a workaround. Why it conflicts with the audio player only on iOS is something I don’t know at the moment. I checked on an Android earlier and it was working fine. Use this please in a custom CSS plugin:

@media only screen and (max-width: 1024px) {
	.preloader {
		display: none !important;

Hi thanks, for this.

Hopefully no other people will experience the issue.