Posts not showing up for everybody

Hi,

I had a problem with my most recent post ‘7 habits of a healthy & happy entrepreneur’ not showing up on my homepage for everyone. I got assisted with a solution (delete cache, deactivate caching plugins, clear my browser cache) and now it is visible.

However, there are 2 problems which may or may not be connected to the original problem.

  1. The most recent post ‘7 habits of a healthy & happy entrepreneur’ has 8 published comments, but only 3 are showing.

  2. I have a recent post widget in the sidebar, that shows my 5 newest posts:

  • The 7 Habits of a Healthy and Happy Entrepreneur
  • How to Find your Ideal Business Partner
  • The Ignored Secret to Successful Entrepreneurship
  • Self-Discipline: How to Take Full Control of your Life
  • Has Society Failed Older Entrepreneurs?

If I’m reading the last 2 posts (self-discipline and older entrepreneurs), everything is fine.

However, if I’m reading the posts on ignored secrets and business partners, the recent post sidebar does not include my most recent post (7 habits). Instead, the business partner post is shown as the most recent of all my posts.

Furthermore, when I look at the posts on ignored secrets, business partners, and 7 habits, the admin sidebar is not showing.

There is a problem with the top 3 posts, and I’m not sure if this because of the cache (which I’ve already deleted).

I’d appreciate your help, and I hope this makes sense to you.

Hello Davina,

You mentioned leverage cache plugin in your previous topic. I think that it can cause something like that. Can you please provide the content of your .htaccess file? It is located in root folder that you can access via SFTP or cPanel, but make sure that hidden files are showing, it is hidden file.

Kind Regards, Roman.

Sorry for the late reply, here it is:

BEGIN iThemes Security - Do not modify or remove this line

iThemes Security Config Details: 2

# Enable the hide backend feature - Security > Settings > Hide Login Area > Hide Backend
RewriteRule ^(/)?wplogin/?$ /wp-login.php [QSA,L]

# Protect System Files - Security > Settings > System Tweaks > System Files
<files .htaccess>
	<IfModule mod_authz_core.c>
		Require all denied
	</IfModule>
	<IfModule !mod_authz_core.c>
		Order allow,deny
		Deny from all
	</IfModule>
</files>
<files readme.html>
	<IfModule mod_authz_core.c>
		Require all denied
	</IfModule>
	<IfModule !mod_authz_core.c>
		Order allow,deny
		Deny from all
	</IfModule>
</files>
<files readme.txt>
	<IfModule mod_authz_core.c>
		Require all denied
	</IfModule>
	<IfModule !mod_authz_core.c>
		Order allow,deny
		Deny from all
	</IfModule>
</files>
<files install.php>
	<IfModule mod_authz_core.c>
		Require all denied
	</IfModule>
	<IfModule !mod_authz_core.c>
		Order allow,deny
		Deny from all
	</IfModule>
</files>
<files wp-config.php>
	<IfModule mod_authz_core.c>
		Require all denied
	</IfModule>
	<IfModule !mod_authz_core.c>
		Order allow,deny
		Deny from all
	</IfModule>
</files>

# Disable Directory Browsing - Security > Settings > System Tweaks > Directory Browsing
Options -Indexes

<IfModule mod_rewrite.c>
	RewriteEngine On

	# Protect System Files - Security > Settings > System Tweaks > System Files
	RewriteRule ^wp-admin/includes/ - [F]
	RewriteRule !^wp-includes/ - [S=3]
	RewriteCond %{SCRIPT_FILENAME} !^(.*)wp-includes/ms-files.php
	RewriteRule ^wp-includes/[^/]+\.php$ - [F]
	RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F]
	RewriteRule ^wp-includes/theme-compat/ - [F]

	# Disable PHP in Uploads - Security > Settings > System Tweaks > Uploads
	RewriteRule ^wp\-content/uploads/.*\.(?:php[1-6]?|pht|phtml?)$ - [NC,F]

	# Filter Request Methods - Security > Settings > System Tweaks > Request Methods
	RewriteCond %{REQUEST_METHOD} ^(TRACE|DELETE|TRACK) [NC]
	RewriteRule ^.* - [F]

	# Filter Suspicious Query Strings in the URL - Security > Settings > System Tweaks > Suspicious Query Strings
	RewriteCond %{QUERY_STRING} \.\.\/ [NC,OR]
	RewriteCond %{QUERY_STRING} ^.*\.(bash|git|hg|log|svn|swp|cvs) [NC,OR]
	RewriteCond %{QUERY_STRING} etc/passwd [NC,OR]
	RewriteCond %{QUERY_STRING} boot\.ini [NC,OR]
	RewriteCond %{QUERY_STRING} ftp\:  [NC,OR]
	RewriteCond %{QUERY_STRING} http\:  [NC,OR]
	RewriteCond %{QUERY_STRING} https\:  [NC,OR]
	RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
	RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [NC,OR]
	RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [NC,OR]
	RewriteCond %{QUERY_STRING} ^.*(%24&x).* [NC,OR]
	RewriteCond %{QUERY_STRING} ^.*(127\.0).* [NC,OR]
	RewriteCond %{QUERY_STRING} ^.*(globals|encode|localhost|loopback).* [NC,OR]
	RewriteCond %{QUERY_STRING} ^.*(request|concat|insert|union|declare).* [NC]
	RewriteCond %{QUERY_STRING} !^loggedout=true
	RewriteCond %{QUERY_STRING} !^action=jetpack-sso
	RewriteCond %{QUERY_STRING} !^action=rp
	RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$
	RewriteCond %{HTTP_REFERER} !^http://maps\.googleapis\.com(.*)$
	RewriteRule ^.* - [F]

	# Filter Non-English Characters - Security > Settings > System Tweaks > Non-English Characters
	RewriteCond %{QUERY_STRING} ^.*(%0|%A|%B|%C|%D|%E|%F).* [NC]
	RewriteRule ^.* - [F]

	# Reduce Comment Spam - Security > Settings > System Tweaks > Comment Spam
	RewriteCond %{REQUEST_METHOD} POST
	RewriteCond %{REQUEST_URI} /wp-comments-post\.php$
	RewriteCond %{HTTP_USER_AGENT} ^$ [OR]
	RewriteCond %{HTTP_REFERER} !^https?://(([^/]+\.)?businessbrokendown\.com|jetpack\.wordpress\.com/jetpack-comment)(/|$) [NC]
	RewriteRule ^.* - [F]
</IfModule>

END iThemes Security - Do not modify or remove this line

Use PHP5.4 Single php.ini as default

AddHandler application/x-httpd-php54s .php

BEGIN WPSuperCache

END WPSuperCache

BEGIN WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

END WordPress

Hello Davina,

I still think that it is caching issue. Looks like it needs extensive debugging, but this goes beyond our support policy.

As an option, you can contact Codeable for this kind of service, or find a freelancer on Upwork.

Kind Regards, Roman.

I understand.

I have one more question. When you are customizing your theme, are your plugins momentarily deactivated?

I’m asking this because when I go to appearance>customize, everything wrong with the comments, sidebar, and admin bar corrects itself. Thanks

Hello Davina,

I don’t think that plugins are deactivated when customizing the theme, I never noticed something like that.

I’m not sure what do you mean in second part of your question, can you please provide more details?

Kind Regards, Roman.

Hi Roman,

I’ve asked you for help with 3 main things:

  1. There are 8 comments on my most recent post but only 3 are showing
  2. My most recent post is not showing on the ‘recent post’ sidebar widget
  3. My 3 latest posts do not show the admin bar which is supposed to come when I’m logged onto my WP dashboard

However, when I go to customize my Sydney theme and my site appears with the choice to edit its appearance, these 3 problems go away. The site is perfect.

You said above that you believed these 3 problems are probably a caching plugin issue, and that’s why I’m asking whether plugins are temporarily disabled when you are customizing your theme.

I hope it makes more sense now.

Thanks,
Davina

Hello Davina,

I think that plugins are not deactivated, however I’m not 100% sure about that. But anyway, this issue requires extensive troubleshooting.

Kind Regards, Roman.

Hi Roman,

It seems like it’s a caching issue like you’ve been saying for days :slight_smile: Some of the pages have started resolving themselves, and it leads me to believe that even though I deleted the cache and deactivated the caching plugins, there are still some files wrecking havoc on my site.

WP Super cache looks to be the culprit, as many reviewers have reported the same problems as mine.

Should I remove this from my .htaccess file?

BEGIN WPSuperCache

END WPSuperCache

Hello Davina,

I think that it doesn’t matter, because these lines are just marks.

Kind Regards, Roman.

Okay, thank you for your help Roman.

Have a nice weekend!

You are welcome Davina,

And have a nice weekend as well :slight_smile:

Kind Regards, Roman.