Polylang doesn't show SydneyPro strings for translation

I’m trying to get the header slider texts translated in a second language. Using polylang I searched for the language strings in “Languages>Translation of strings” … I do find various PlugIn listed here with their language strings - but not Sydney. What do I need to do to get the Sydney strings added to the polylang database - to be displayed in the string-translation section?

Cheers, Timo

Hello Timo,

First thanks for using our theme!

By just installaing the Polylang plugin the Sydney Pro strings should appear:

Please let us know which version of Sydney Pro you using. Is the latest ? You are with a child theme active ?

Kind Regards,

Rodrigo.

aThemes Support

Hi Rodrigo!
Thanks for your answer! Are you new to the team? :slight_smile:
Actually I don’t get the Group Entries “Sydney Pro” as you can see

image

I’m using a child Theme:
Sydney Pro Child Version: 2.1.4 (1626045463) and Polylang 3.0.6
Should all be the latest version.
Any help would be appreciated.
Cheers, Timo

1 Like

Hello Timo,

Yes, I am new in the aThemes team. Nice to meet you! :slight_smile:

Probably the issue is related to your child theme. Please try following the steps below:

  1. Download the latest version of child theme here: Child theme for Sydney Pro - aThemes Knowledge Base
  2. Extract the wpml-config.xml file inside your current child theme. Or just use this new child theme (keeping your custom changes).

We have made some changes regarding this in the latest release of Sydney Pro as you can see here:
https://athemes.com/changelog/sydney-pro/

We hope this helps!

Please try that and let us know if you need further assistance.

Kind Regards,

Rodrigo.

aThemes Support

Hi Rodrigo, welcome to the outstanding support team!
I downloaded and temporarily installed the Sydney Pro Child theme … still no change. Sydney Strings are not displayed in the groups:

any additional ideas?
Cheers, Timo

1 Like

Hello Timo,

Thank you very much! :slight_smile:

Hmmm. Probably because the Polylang not filtered your Apperance > Customize options. Please try going to Appearance > Customize and change any text field to some new text/value. Eg: If you have the footer credits text enabled, go until this option and change their current value to something like “My current footer credits value 2”. Save/publish. Then back the option to original value (without the “2”). Save/publish again.

Go to the Strings Translation page and see if the text appear in the group “sydney-pro-child”:

If this works, you will need do the same for all text fields inside the Appearance > Customize.

If even so still not works, we will need do a inspection directly from your website. Just in case it is related to site specific issue. Thus I request sharing your website’s temporary admin login link and send it privately to me over email. You can generate the link with this plugin .

Email

rodrigo@athemes.com

P.S.: Ensure the link expiry is set to 7 days and all admin rights are enabled.

We hope this helps!

Please try that and let us know if you need further assistance.

Kind Regards,

Rodrigo.

aThemes Support

Hi Rodrigo,
thx for your support. The site is a new setup (early stage) … nevertheless I edited quite some content in the customized fields of Sydney Pro … (also footer widget credits) … so I can’t imagine this causes the problem … I send you an admin access mail …

Cheers, Timo

Hello Timo,

First sorry the delay here, the response time can increase on weekends. I reveived the access to your website in my email, thanks!

I did a inspection and discover that a custom JS code was changing the slider text at Appearance > Custom Javascript. And this is the reason of slider text not being translated.

Also, saw that the child theme activated was without the wpml-config.xml file. Then, I switched to the child theme that has this .xml file.

  1. I removed/commented the code, as you can see at Appearance > Custom Javascript.
  2. Changed the slider texts at Appearance > Customize > Header Area > Header Slider with the child theme activated, so the Polylang is able to discover and translate these new texts.

Go to the String Translations and see it working now. I’ve also added a footer credits, only for testing purpose that you can simply remove through the Appearance > Customize > Sydney pro: Extra Options.

In resume, the main culprit of the issue was the JS code being added through Appearance > Custom Javascript and the child theme without wpml-config.xml file.

We hope this helps!

Let me know if you need further assistance.

Kind Regards,

Rodrigo.

aThemes Support

Hi Rodrigo,
thank you very much for giving the topic such a detailed examination! Very much appreciated. For my next project I will start of with the child theme you provide instead generating one by a common PlugIn.

Just one little question: The additional JS was copied from the athemes SydneyPro forum (provided by the athemes support) to be able to include a line break in the slider headline. By disabling the JS of course there is also no more line break available. Would you have a suggestion how to achieve this feature now?

Thanks again for you help!
Cheers, Timo

Hello Timo,

Ah sorry! I did not perceive that. In this case we need keep the JS code, but we need check what’s the current language enabled and then show the respective text.

I already did this change for you at Appearance > Custom Javascript. Please take a look in the code there.

We hope this helps!

Let me know if you need further help.

Kind Regards,

Rodrigo.

aThemes Support

Great Rodrigo! Thanks very much.
I just wonder if it will be enough to copy the wpml-config.xml file to my old child theme to maintain my settings from that theme - or will it be necessary to keep the Atheme Sydney Pro child theme to keep things workling?

Great support!
Cheers, Timo

Hello Timo,

Great! You are welcome!

You can simply move the xpml-config.xml to your old child theme.

If you need further assistance feel free to contact us.

Knd Regards,

Rodrigo.

aThemes Support