Parallax Refresh Positioning CTRL F5 NoCache

Hey Team,

i searched the net for 3 hours but did not find any fitting solution. If i refresh the page with cache disabled or Ctrl-F5 (like any new page customer comes in) the parallax effect does not load the picture properly. I found some posts around that bootstrap bug but noone seems to get it fixed without JS changes.

See Picture Paralaxx Above shows how it should look like. Lower picture is greyed out partialy.

Some guess that it trys to set parallax position while loading upper pictures and sets the position wrong. They advise to delay parallax picture loading on JS. Maybe you have a guess what could help?

You can reproduce that behavior on the page itself. https://renditejoker.de

Happens to me on every browser without caching or CTRLF5. Also found some suggestions here: https://github.com/pixelcog/parallax.js/issues/128

Bought your theme 3 days ago. Except this problem everything works perfect.

Thank you in advance

Hello Tobias,

I have just checked the page that you mentioned above (https://www.renditejoker.de/), but I didn’t see the issue that you described. Have you already resolved your issue?

Kind Regards, Roman.

Hey Roman, i just switched it off some hours ago as i could not find a solution until now. I put it back for you to check :slight_smile:

Thank you for your help.

You can easily reproduce it by CTRL-F5 then scrolling down or without cache surfing on firefox. Also on chrome but not that often.

Best regards

Hello Tobias,

Please try to temporarily deactivate all your plugins except Sydney Toolbox and Page Builder by SiteOrigin, and see if it helps.

Kind Regards, Roman.

Hey Roman,

I did as mentioned. Every Cache, plugin etc disabled. Still the same problem :frowning:

I can not reproduce this problem on your demo page http://demo.athemes.com/sydney-pro/. I did no changes to the template code or anything. Disabled the little CSS adds as well.

The only difference I can guess is that its related to HTTPS or PHP version running on the server? Its running on 7.1-latest FPM (P+). Is there a minimum parallax picture height I need?

Best regards

Hello Tobias,

As a workaround, you can try to use the following CSS code.

You can add CSS code in Dashboard → Appearance → Customize → Additional CSS (WordPress 4.7 and up).

.panel-grid .panel-row-style {
    background-position: center !important;
}

Kind Regards, Roman.

Thank you very very much for the support :slight_smile: Worked out perfectly fine.

Best regards

You are welcome Tobias! :slight_smile:

Kind Regards, Roman.