Page template not changeable on WooCommerce pages

Hello,

I’m using Sydney Pro theme for a few months or more, but now I’ve installed WooCommerce 3, to launch a shop, and I have small problem. The site is available here: www.krakow.smileflow.pl and the shop is here www.krakow.smileflow.pl/sklep The problem is, that I cannot change shop’s page template. So usually on normal pages I can choose from let’s say: Contact, Featured header image, Featured header image - Wide, Front Page, Full Width, Login, No header image and No header image - Wide. But on the shop page, there’s no such setting. At the moment when people click any product in the shop, the page reloads, and they see slider, have to scroll all the way down every single time. Also at the left side there’s a contact form which shouldn’t be there, and I also can’t remove it. So is there any solution which would resolve this problem, so that for example on all shop related pages I wouldn’t have slider, just narrow image at the top, and no sidebar on the left?

Regards,
Richard

Hello there,

WooCommerce system doesn’t use shop page’s attributes and uses only its URL. This is default system we can’t modify. In short, shop page is a special page.

In order to disable main slider on WooCommerce pages and use header image instead, try the steps below.

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box
    jQuery(function($) {

      if( $('body').hasClass('woocommerce-page') ) {

        $('.sydney-hero-area .header-slider').remove();

        $('.header-image').show();

        var img = 'http://yoursite.com/path/to/image.jpg';

        $('.header-image').css('background-image', 'url('+img+')');

      }

    });

Repace http://yoursite.com/path/to/image.jpg with valid image URL of your preference. You can get if from media library under Dashboard > Media.

  1. Update

Afterwards, flush applied cache to allow your site loads the recent code addition.

https://codex.wordpress.org/I_Make_Changes_and_Nothing_Happens

Regards,
Kharis

To accomplish it, add this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .woocommerce-page #secondary {
      display: none;
    }

    @media only screen and (min-width: 992px) {
      #primary.col-md-9 {
        float: none;
        margin-left: auto;
        margin-right: auto;
      }
    }

Regards,
Kharis