Page not swowing

As I have more posts on the site now, I have the option on the main page to click on “older posts”. When clicking on it, the error “Not Found

The requested URL /page/2/ was not found on this server.” is showing

(check here: http://www.olaszmamma.com/page/2/)
I have already saved the permalinks, but that did not fix it.
could yu please help?

Hi,

Try changing the permalinks to default please and save it. Then switch back to custom.

If that doesn’t fix it try disabling all your plugins to check.

Hello, I have tried to do this, but wonüt work. When I change the permalink to the http://www.olaszmamma.com/?p=123 format , the older osts page will generate, but switching back to the http://www.olaszmamma.com/2016/02/28/articolo d’esempio/ format it will display the The requested URL /page/2/ was not found on this server.” error again.

Also tried to disable all plugins, but did not help.
Anz other suggestions pleaseÜ

Hi,

In this case, it’s probably an issue with mod_rewrite on your server. You’ll have to ask your host to check this out as there’s not much we can do here.
You can also try checking if this happens with a different theme, though the results should be the same.
Let me know what happens please.

and to sort this out temporarily, is there a way to remove the “older posts” tab? at least noone clicks on it if not visible

There is a way with some custom CSS. But why not go to Settings > Reading and increase the number of posts so you can show all your posts on the homepage?