Page Header Top Padding/Logo

Hello!

I am finding that my site logo shows up not just on my homepage but on all other pages. I don’t really want it to and I’m also finding that my pages all have large unnecessary padding at the top. I can not find where to adjust that.
E.g my website http://stone.joshschuyler.com/wp-admin/ has a page “Shop” (found on upper right hand menu of homepage), when clicked and on that page, you can see there is a large white padding on top and the logo I used on the homepage also appears. How can I make it so the logo only appears on the homepage, and not the other pages?
Screengrab explanation attached!

Thanks!
Cailley

Hello there,

To hide the logo on inner pages, add this CSS code to Appearance > Customize > Additional CSS from dashboard.

    body:not(.home) .site-header .col-md-4 a {
      display: none;
    }

To get rid of the unnecessary spaces, edit your first row in that page, under Row Styles > Layout; set 0 onto the Top/bottom padding option.

46

Regards,
Kharis

Hi Kharis,

Thank you so much! The css code has removed the logo.

The padding doesn’t seem to be going away (see screengrab, where it says Home/Shop" on the left and there’s a search bar on the right - I’d be fine with getting rid of the search bar.)
The padding seems to influence the second screengrab, further down on the page.
Thanks!


Hello there,

The solution might be this CSS code:

    #pl-2602 {
      margin-bottom: 60px;
    }

Add it to Appearance > Customize > Additional CSS from dashboard.

Regards,
Kharis

Hi,

That does adjust the area indicated in the second screengrab above. However, I’m more interested in getting rid of the white space at the top of the page (in screen grab below). And do you know how I might get rid of the Search bar in the upper right hand corner?
Thanks for your help!
Cailley