Page can't be found

Hi,

I entered the my services in the theme (sydney), and then I created pages with the same name.
After that I realized that they both shared the same slug and that I can’t access my pages. When I open them they go to the sydney pages. So, I deleted the services, disabled the pluging, and flushed parmalinks, and my pages worked again.
I created the services under bogus names: service 1, service 2, etc. Then when they had a slug, I renamed them to match my actual services.
Now, my pages won’t work unless the plugin is disabled.
I tried deleting the plugin, reinstalling it, and importing the services again after vetting the xml file. Still not working.

website: https://wp.sahabyah.com

Btw, when I tried to import the backed up xml, it told me that the posts were already existing.

Hello there,

The Sydney Toolbox plugin inserts some required custom post types like services, employees, clients, etc. When they exist, WordPress system will automatically creates their archive pages. For services, it will be yoursite.com/services. If your page has the same permalink structure, it won’t work as it will always be redirected to the post type archive page. The solution is to rename your page to become our-services or something else you’d prefer, so its URL will be yoursite.com/our-services.

Regards,
Kharis