Page behave like there's no header anympre

Hi!

I never had problem with my website and this week seems terrible! Now, my problem is that every page on my website are slightly higher, the content has moved up, behind the header menu like there’s no menu or no header anymore. I can see the bug only when I’m not connected on my Wordpress, like everyone could see, not when I’m connected. So I don’t know how long the problem it’s there, someone just told me.

Can you help me! I didn’t make any major change. I know a plugin I’ve installed caused me some problem when updating : coming soon and maintenance plugin. I deleted it, just in case, but…

www.hannamontreal.com

Thanks a lot :slight_smile:

I’m using “page builder” on each page. I tried something on my “galerie” page, I tried to use only the text code, the original editor, but nothing had changed so I opened again the “page builder” to add my gallery on it and the problem is less important, I mean my pictures are slightly lower than before, but still, the problem is there! Every other pages haven’t changed and have the issue. So, a change occurred only on the page I played with. Maybe my page builder is causing problem? I still can’t see the problem when connected.

I just saw that I see the problem when I’m on the « personalization » page, when I see the website in realtime. But still not when I’m connected to my dashboard and open my website on another tab. I don’t know if this information will help or not but, I really don’t know what to do!

Thanks for your help :slight_smile:

Nobody has the same problem, no one can help me?

Thanks

OK, well, I’m alone talking in my thread, maybe someone would need the advice, I found the problem (yey!)

I don’t know how to solve it but I need to use now the « sticky » menu instead of « static », which is not perfect for the front page but the best to get rid of the bug! I discover the bug just after the last theme update at the beginning of the last week, and can’t use the « static » menu anymore. So, I found this was a good idea to share.

Hope the next update will include something to fix it :slight_smile:

Hello there,

I would like to apologize in advance for the delayed respond.

It isn’t considered as an issue. If you wish your inner pages to not have a header image (no image set in the "Header Image’ options), in the “Site header type” option you must select “No header (only menu)”. Otherwise, the header won’t be displayed. Go to Appearance > Customize > Header Area > Header type > Site header type > No header (only menu)

Regards,
Kharis

Bonjour M Kharis Sulistiyono,

No, this is irrelevant. I never had a header image, let me show you (of course you couldn’t see it because I manage something to resolve the bug).

I have some pictures. For 10 months I used the option « sticky menu » and all worked well. This is what you should see and how it was for 10 months (yes, with the « no header option, only menu):
http://postimg.org/image/bgvuo5g2v/
http://postimg.org/image/ekw35wmq7/

As you can see, the padding before the content starts at the bottom of the « header », which is black with a static menu, like it’s supposed to look.

Then earlier this week, I made an update and everything was upper on the page, like the padding starts now at the beginning of the header and not at the bottom, it’s like I have no header anymore or it’s not existing however it’s there, the bug looks like this:
http://postimg.org/image/txq9eyw13/
http://postimg.org/image/k9a23n51d/

I think you can see well. On some page, the first sentences were hiding behind my black header, and as you can see, I have a password protected page, we couldn’t enter the password because it was hiding behind my header, not convenient at all! And I can’t add a padding to center the content because it’s working fine on a mobile device. But it is only after some tests that I found out that I needed to use the « sticky menu » now to have my content at the right place on my page. I didn’t make any major changes, but I did make a theme update. So now it’s almost right and looking good, how it’s supposed to be: http://postimg.org/image/bgvuo5g2v/

But I’d rather use the « static menu », it looks better on the front page than with the sticky menu. It’s not totally a win…

So yes, in conclusion, the « static menu » option does not work well anymore. At least, on my side. And I showed you.

I hope you understand the problem better now!

Thanks for your time,
Hanna

SORRY! I made a mistake in my first paragraph : For 10 months I used the option « STATIC* menu » and all worked well.