No SSL pad lock in home page due to image in theme

We are using Airi Creative Agency theme for our website SSISGen,other than home page all other pages have pad lock in url, when i asked bluehost they told me its because of image which is in insecure location,could you suggest me how to change this image?

Message

An image with an insecure url of “http://demo.athemes.com/atu-agency/wp-content/uploads/sites/86/2018/06/books-business-computer-459654.jpg” was loaded on line: 464 of https://ssisgen.com/.

Hello there,

Try downloading it to your drive. Deleting it from your page and re-uploading it.

If it doesn’t resolve the issue. Try to install and activate this plugin:

Regards,
Kharis

Problem with this image is, its not on the page but embedded somewhere in theme as its homepage.

Hello there,

I inspected the demo file and yes it comes from there. If you want me to fix it, please share site’s admin username and password to kharisblank@gmail.com; mention the link to this topic to help me easily recognise your coming.

Regards,
Kharis

Hi Kharis,
I am a software developer as well, i think you are going to edit in theme editor, if you could point me to the right file inside it i would go in and edit it myself.
P.S. i was sceptic about changing theme as it might get overwritten when they update the theme.

Hello there,

Firstly download this image to your drive. Edit your homepage with Elementor. Choose the first section that contains main large hero.

23

In the left panel, go to Style options. Remove the background image and upload the new one.

Regards,
Kharis

Thanks that worked, i thought i already changed that but looks like i didn’t. thank you for all your help.

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis

Hi, I seem to have the same problem. I replaced the background image with a new one but the issue persists. I even deleted the original image from my media library and uploaded a new one in place. But I am still getting the follwing mixed content error, Is there another way to fix this?
Soft Failure
An image with an insecure url of “http://demo.athemes.com/atu-agency/wp-content/uploads/sites/86/2018/06/books-business-computer-459654.jpg” was loaded on line: 641 of https://rutudesai.com/.

Hello there,

Thank you for reaching out to us.

I did inspection in your site’s source code and I found an active caching.

You should have to flush it after applied some changes otherwise your changes won’t be sent to the front-end due to the web browser only load the cached version of your site.

I request you to flush the cache from dashboard as I found it has been enabled with a particular plugin or you may be able to do the same from the plugin’s settings panel.

​I hope this reply helps.

Regards,
Kharis
aThemes Support