No "Front page" template?

There are no Front page template option in Page attributes, only default, full width and Page Builder, why is that?

When choosing a background image, the image does not cover the full width of the page, even when the Full width page attributes option is chosen?

Best regards
Carsten

It’s called Page Builder now, people were getting confused in previous themes and were thinking that the Front Page template can only be used on the homepage, which was not true. So we changed the name.

You mean for a row in the page builder? Or show me a link please.

There is documentation here: athemes.com/documentation/talon/

>You mean for a row in the page builder? Or show me a link please.<

Yes, when setting up a background image, with page template set to Page Builder, it only covers the main row, not full width like in the “old” Front Page setting.
And the widgets background turns transperant.

This is also the case when template is set to Full Width, the only difference is that the row widgets background are not transparent.

btw. these widgets are, to my knowledge, Sydney widgets, it’s great, but why do they still show in Talon?

Best regards
Carsten

The background image you’ve set (or at least at the moment) is for the whole body, not for a row.

If you want your row to have an background image you need to go to Edit Row > Design, and then to make it full width you need to go to Edit Row > Layout and select Full Width.

They’re not Sydney widgets exactly. Some of them do the same thing since they’re still services, employees etc.

Hi Vlad

>If you want your row to have an background image you need to go to Edit Row > Design, and then to make it full width you need to go to Edit Row > Layout and select Full Width.<

Hmmm, this is strange, when I go to Edit Row, only the edit of columns is possible, the sidebar with other options has disappeared?

Best regards
Carsten

Perhaps the page builder is conflicting with something on your website. It looks fine to me.
Send me an admin account if you want at vlad[at]athemes.com so I can have a look.

I still don’t get it, all the rows are set to Full Width, but still the background image does not cover the background?

In the appearance >customize >background image section, there are way of controlling this?

I’ve told you in this topic and over email: there is a difference between a site background image and the row background image.

  1. Site background image is what you have now and it’s set from Customize. It applies to the whole body on the whole site. It’s a core WP option.
  2. Row background images are set to specific Page Builder rows, like it is shown in the documentation and like it was in Sydney.

So now you have an image from Customize > Background Image which has no relation to the Edit Row options. It’s just an image that’s not big enough to cover everything.

>It’s just an image that’s not big enough to cover everything.<

Strange, the image is 1024x768, the same size as the header image which covers the full width

The header image is stretched by the theme so that we can make sure the slider is full screen. The background image is not controlled by the theme.

Changing theme back to Sydney, the same background image 1024x768 actually covers the full screen, that’s why I am confused.

It’s the exact same result in Sydney too if you use the same settings you have now (no repeat, fixed and center). Maybe could only be different if you have some custom code.

Well, the result is not the same for me, even when bypassing the child theme customization code, by using the main Sydney them without customizations, the background image covers the whole page.

But never mind, I leave Talon and stick to Sydney again.

Cool. But again, you have different settings for Sydney. You’ve set the image to Repeat while for Talon you had it to No Repeat.
Right now it doesn’t cover the background per se, it just adds the image more times.

True, I was not aware of that.
I changed it, and now the background image is covered by the header image slider…

I don’t want to use a background image, but just wondered why it did not work as expected.

That’s what I keep saying, that background image applies to your site’s body, which contains various elements, like the slider. Every element that’s not empty, including the slider will go on top of the body background image :slight_smile:

ok, I understand, so having a background image, covering the full width and also the body underneath the slider, takes an huge image with longer page loading time, as result of this