Newsanchor Pro causing Gateway Timeout 504 on the server?


Hello everyone,

My site: is hosted with and I am getting “Gateway Timeout 504” errors when I am saving as draft or publishing. The good people at Siteground have asked me to disable all plugins and do all sorts of things. Has not helped. Now (I think) they are blaming the theme in their latest update of the trouble ticket:

It seems that the plugin causing the issues is not the removed one. I have checked the server's logs once again and confirmed that the origin of the issue is not recorded. Please disable all plugins for testing purposes and check if the issue still persists. If yes, then I would recommend you to change the theme, because the theme is loaded even when you are working on the backend of the application. If the issue is resolved after disabling of the plugins, then you should activate them one by one in order to find the exact one that is generating the so slow process.

The people at Siteground suggests that I should change theme to avoid these errors. What is your view on the statement that the theme is causing this?



Actually the’ve told you that the plugin which caused the issue wasn’t removed, so if by removing all plugins the issue is not resolved, then change the theme ( activate an other theme ) and check if with that the issue will be resolved, if the other theme activation resolves the issue, then please get back to Us, so we can inspect the issue further on your site / in theme ( the theme was tested and it didn’t cause any issue like that, so there must be a plugin conflict )>

Best Regards,


After many and long discussions the hosting company admitted that it was a problem with one of their settings. Problem fixed. No fault at all with the theme.



Great! I’m glad it’s resolved! If you need help with anything else, please open a new topic.

Have a nice day!

Best Regards,


I’m having a similar problem and can’t access my theme’s configuration page. What setting did you get changed?


Hi Ben,

Please get in touch with your hosting company, so they can fix your issue too.

Kind Regards,