New post not showing on homepage

Hi,

Yesterday I published my newest post ‘The 7 habits of a healthy and happy entrepreneur’. I did everything as usual (formatting, posting etc), and shared links which are working fine.

However, when I look at the home page of my blog where my posts appear, my newest post is not visible. It’s also missing from the ‘new posts’ list on the sidebar. I have to access it via a link or via the dashboard.

I’ve checked my home page on 2 other computers, one shows the newest post and one doesn’t. Does anyone know why this is happening? It hasn’t happened before.

Here is my blog: http://www.businessbrokendown.com/

P.S. This is not an issue with my browser cache

Hello @Davina14,

  1. Do you use some caching plugin? If yes, please try to clear its cache.

  2. Please try to deactivate all your plugins except recommended and try again.

  3. Please try to activate default Twenty Sixteen theme and see if it helps.

Please remember about importance of regular backups.

Kind Regards, Roman.

Hi Roman,

  1. I use leverage browsing cache and WP super Cache. I’ve deleted the cache but still no change. I’ve also tried deactivating the plugins but no change.

  2. I live previewed the 2016 theme and the newest post is showing. Does that mean the problem is with Sydney?

Thanks,
Davina

Here’s something strange Roman.

I went to customize Sydney, and the newest post was showing. But when I revisited the site, the post was not visible.

Okay Davina, I still believe that it is caching issue. Can you please delete cache in those plugins, deactivate them, clear your cache in browser, and try again?

Kind Regards, Roman.

Also please try to activate (not only preview) Twenty Sixteen theme and see if it helps. And then preview Sydney theme.

Also I suggest you to ask your hosting provider if there is some server-side cache enabled.

And one more thing, you can try to switch to Classic blog layout in Sydney Customize options.

I really hope that it will help you.

Kind Regards, Roman.

Hey Roman, you’re a gem. It seems like it was the cache problem all along, I was deactivating the plugins but not clearing my browser so the change wasn’t being reflected.

I’m going to keep an eye on the site, and maybe in a few days I’ll reactivate the plugins or install another cache plugin.

Thanks for being a big help :slight_smile:

You are welcome Davina,

And have a nice day :slight_smile:

Kind Regards, Roman.