Navigation Menu dissapears after homepage

Hi there,

I am hoping you can help me…

I have two sites I have created using exactly the same theme “Airi”.

One of them has been successful and the other one I am having an issue with:

  1. homecarebusinesssupport.co.uk - the mobile menu works fine on all pages
  2. rejuvenatenaturally.co.uk - the mobile menu works on the home page, but every other page - it just dissapears!?!

I do not get it? I am at a lost end… I have tried everything, I am using exactly the same settings, I have even copied and pasted the css from Home Care Business Support over to Rejuvenate and it is still not working?

Please help me. I am not too techy, I get the basics of CSS / HTML etc, but am not too advanced.

I look forward to your response.

Best,
Louis

Hello Louis,

I’m not sure why it happens, but you can try to use the following CSS code as a workaround. You can add CSS code in Customize → Additional CSS section.

#masthead {
    position: absolute;
}

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.
aThemes Support

1 Like

Hi Roman,

Thank you very much for your swift response. It is definitely an improvment. However, if I could get you to look at my othersite (homecarebusinesssupport.co.uk) - you will notice that it is a sticky header with a background colour.

With the fix you have given me Rejuvenate Naturally, although the menu is now appearing, when you scroll down the page, it then dissapears?

Hope that makes sense?

Best,
Louis

Hello Louis, you are welcome.

I checked both your sites once again and saw that the header is sticky on both.

Please note that mobile header isn’t sticky by default, it’s completely normal.

Kind Regards, Roman.
aThemes Support