Navigation font colour on mobile


#1

On mobile devices the text in the 2nd level of navigation is black, rather than
the specified colour. On desktop it is fine.

Is there a reason why the 2 menus will have different colour schemes? And how do I fix it so mobile is identical to desktop?


#2

I see it black on desktop too. I think Autoptimize might be causing some cache issues.
Also, I cannot open your mobile menu to check - again, it’s either Autoptimize messing up the script or you made changes to the functions.php file.


#3

I have deactivated the Autopimize plug in - but still have the same issue on mobile with the black background.

I have not made any changes to the .php file, the only changes I have made are to the custom CSS.


#4

I still cannot open your mobile menu to check the issue. Is it opening for you?


#5

Hi Vlad:

The mobile issue is still there.

I disabled every plugin and I still could not get the mobile nav to respond. I tried in Safari and Chrome. I have not made any changes to php files.

I am reactivating the plugins at the moment, but you have been granted an admin account if you wanted to inspect anything.


#6

I literally have no idea what the issue is here. There are no errors and everything seems to be in order.

Do you remember if you did anything before the mobile menu stopped opening? Also, is it cool if I reinstall the theme?


#7

hi Vlad:

I really can’t think of anything. I did notice the issue happened after I’d installed the wordpress update and the various plugins.

No problem for you to go about reinstalling - but I am assuming the content of the site will not be lost? (that would not be good!)


#8

Alright, reinstalling the theme fixed the issue. Not really sure how the menu broke if you didn’t do any changes to the files.

Regarding the color, it’s black because you’ve set it to black in the custom CSS plugin. If you would like to change it for the mobile menu, simply add this:


@media screen and (max-width: 991px) {
    .main-navigation ul ul a {
        color: #fff;
    }
}


#9

Thank you Vlad, for both fixes.

Are you aware of any issues with Autoptimize? Is there any other more stable option to use, such as Better WordPress Minify?


#10

Autoptimize should work too, you probably just need to make sure you clear its cache after you make changes. Just a note: all the scripts used in the theme (except 1-2 really small ones) are already minified.