My site is not working in Internet Explorer


#1

My site will load correctly in Chrome/Firefox/and Safari. But will only show the loading icon on Internet Explorer, I can see that it scrolls but I am unable to see the site content.


#2

Hello there,

What version of IE are you running? Is it the latest one?

Regards,
Kharis


#3

yes the latest version IE 11, I also tried deactivating all plugins and
still had this issue.


#4

Hello there,

There might be a script compatibility issue on IE 11 which can’t completely execute script of pre-loader. To check if it’s an issue with the theme, please test our Perth Pro demo.

In your case, you might need to disable the pre-loader on IE 11 by adding the below CSS code to Appearance > Customize > Additional CSS from dashboard.

    @media all and (-ms-high-contrast: none), (-ms-high-contrast: active) {
      /* IE10+ CSS styles go here */
      .preloader {
        display: none !important;
      }
    } 

Regards,
Kharis


#5

@kharisblank
hi,very thanks,i solve display issue in IE 11 now via your code
and i wanna know
is this code support for anyother wordpress theme,to solve this problem?


#6

Hello there,

That code hides the preloader animation which the class name is .preloader. Other theme might have different one. You should find it by viewing the source code with web browser’s inspector tool.

To target specific CSS code on IE, wrap your code with:

    @media all and (-ms-high-contrast: none), (-ms-high-contrast: active) { 

    }

Regards,
Kharis