My site disappeared when I installed AliZee-Pro


#1

I was working with AliZee. I purchased AliZee-Pro. I uploaded the .zip file by ftp to my host in the wp-contents/themes folder. I unzipped the .zip file. The AliZee-Pro theme showed up in ‘Themes’ in the admin section. When I clicked ‘Activate’ my site entirely disappeared. I get nothing but a blank screen, whether I try to go to any page on the site or the admin. I thought it might be because of plugins. I did a new install of wordpress (different subdomain), installed no plugins, uploaded .zip etc and when I click on Live Preview same thing - nothing but a blank screen.


#2

That’s strange, we’ve not seen such an issue before with Alizee Pro. Could you install the theme from your dashboard, using the Upload Theme button? I’m guessing something went wrong when you unzipped it. First you would need to delete the theme via FTP so your site can revert to Twenty Fourteen in case you have it.


#3

Thanks for the quick reply.

Here is the message when I try to preview in the second/alternate install:

Parse error: syntax error, unexpected T_FUNCTION in /mysite/wp-content/themes/alizee-pro/functions.php on line 204

I can’t install from my dashboard because the file is too big.

Unfortunately, I already uninstalled from the first site NOT using ftp. I will try it with the second one.

On first install - What if I upload the unzipped file by ftp?


#4

So, I uploaded the unzipped folder AliZee-pro to the first install and got the same error message:

Parse error: syntax error, unexpected T_FUNCTION in /mysite/wp-content/themes/alizee-pro/functions.php on line 204


#5

Yeah, you should try uploading the unzipped folder.

That error shouldn’t be there if you haven’t made any code changes, which I’m guessing you didn’t.


#6

I see. In this case I guess your environment doesn’t work well with the option to add custom background colors to each post.

Do this please:

  • open functions.php on your server from the theme folder,
  • search for this: Custom post classes
  • remove this block:

add_filter( 'post_class', function( Array $classes ) {
    static $number = 1;
    $classes[] = 'post-number-' . $number++;
    if ( 7 === $number )
        $number = 1;
    return $classes;
});

  • save your file/reupload it if the FTP clients asks and see after that.

Or if you want you can send the login details to vlad[at]athemes.com and I’ll do it for you.


#7

So, I have tried unzipping the files on my computer and on the host, I have deleted via ftp on both of the installs.

I get the same message on both. On first, original install, on which I activated AliZee-Pro, I got the error message when I uploaded Ali-Zee Pro. Having now removed it by ftp I still only get a blank page and have no access to the site, all I get is a blank page.

The second/alternate one on which I only tried to preview I got the error message when trying to preview both when I unzipped on my computer and in the cloud.

And no, I didn’t change any code.


#8

See my previous message. I’ll try to handle it if you can send the login details.


#9

OK,I made the changes you said to in functions.php. It looks like it is working.

Thanks!


#10

Great. So for some reason your host doesn’t play well with our option that lets you set a custom background color for the posts on your front page. If you plan to use that one, feel free to let me know and we’ll try to find another way that works for you.


#11

Sorry, I didn’t see the update here, I only looked in my email. So far so good. But I have another issue that needs addressing. I will start a new thread.


#12

Had the same problem. The solution to edit the functions.php worked for me as well.