Moesia 1.36 update hides background images, menu, etc

My wife’s site www.kamiliconsulting.com was updated to Moesia 1.36 today. After the update, her background images as well as the menu, etc. are no longer being displayed. Looking at the differences between Moesia 1.35 and 1.36, I see:

diff -rup moesia-1.35/js/scripts.js moesia-1.36/js/scripts.js
— moesia-1.35/js/scripts.js 2015-08-26 13:20:54.000000000 -0500
+++ moesia-1.36/js/scripts.js 2016-01-13 13:30:20.000000000 -0600
@@ -19,8 +19,8 @@ jQuery(function($) {
});

//Page loader
-jQuery(document).ready(function($) {

  •   $("#page").show();
    

+jQuery(function($) {

  •   $('#page').css('visibility', 'visible');
    

});

//Menu dropdown animation

and…
diff -rup moesia-1.35/style.css moesia-1.36/style.css
— moesia-1.35/style.css 2015-08-26 13:20:54.000000000 -0500
+++ moesia-1.36/style.css 2016-01-13 13:30:20.000000000 -0600

@@ -29,7 +29,7 @@ body {
-webkit-font-smoothing: antialiased;
}
#page {

  •   display: none;  
    
  •   visibility: hidden;
      -webkit-animation: fadein 1s;
      animation: fadein 1s;
    

}

If I comment out the “visibility: hidden” hunk above with my debugger, then everything is displayed correctly. May I ask how the javascript in the first hunk is supposed to override the hidden attribute?

Ok, solved. I’ll mention what I had to do here, in case anyone else runs into the same issue. I had made some changes to moesia/js/scripts.js so had copied it into my child theme so my changes wouldn’t get lost on a theme update. That meant my local scripts.js needs the same change that was made to latest parent scripts.js. Adding that change did fix things for us.

Hello @bergner,

I am glad that you solved your issue!

And thank you for sharing a solution :slight_smile:

I have already marked this topic as Resolved.

Kind Regards, Roman.

Hi Bergner,

Thank you for sharing your experience.

It seems I have the same issue – http://www.mibawa.co/

However, I’m not sure I understand what I need to edit in the scripts.js
and what I need to edit in the style.css
(or any other needed edits…)

I’ll be grateful for any guiding you can give. Thank you so much.

It seems to be all fine now… so strange…

Hello @yotam,

Please consider creating your own topic for your question next time to keep forum in good order (and add links to relevant topics there).

Kind Regards, Roman.

Hi @Roman,

Thank you, I apologize. I’ll create my own topic in the future.

Thank you again,
Yotam

Thank you Yotam,

And have a nice day :slight_smile:

Kind Regards, Roman.

:slight_smile: