Moesia 1.14 with IE 11


#1

Hi,

I encounter issues with Moesia 1.14 and IE 11.
Theme is not displayed as expected compared to Chrome or Firefox.
Here is the link:

http://eexplore.fr/v2

This is a fresh install of WP 4 and a child theme of Moesia with no “homemade” CSS in style.css or code in function.php

Any help would be greatly appreciated.

All my best,
Phil


#2

Hello,

I see what you mean.

I checked on my server and I cannot reproduce this issue, neither with Moesia nor with a child theme. Could you disable your plugins and check? Also, is the issue the same if you switch from the child theme to the parent theme?


#3

I had another look and the issue is definitely with your child theme. You’re not importing the parent style.css.


#4

Hi Vlad,

After checking, i just added the following code in function.php and it works @ 90%

add_action( ‘wp_enqueue_scripts’, ‘enqueue_parent_theme_style’ );
function enqueue_parent_theme_style() {
wp_enqueue_style( ‘parent-style’, get_template_directory_uri().’/style.css’ );
}

The only thing i need to investigate is fonts.
I’m using Open Sans and Open Sans Condensed but fonts are totally different in IE 11.

All my best,
Phil


#5

The fonts are actually correct. The difference is that the titles are getting a bigger font weight and the text is getting a different color.

The thing is that they changed the Codex page regarding child themes and wrote there the code you’re using, instead of the old @import method. They didn’t think too much about the implications so now the parent style is loaded before bootstrap.

Try this for now: go to the parent theme functions.php, find this line add_action( 'wp_enqueue_scripts', 'moesia_scripts' ); and replace it with this add_action( 'wp_enqueue_scripts', 'moesia_scripts', 9 );


#6

Hello Vlad,
It works better now :slight_smile:
Thanks so much !

…and for your next update, I suppose that i need to update the line again ?