Mobile site view


#1

Hi,
entering my site from mobiles, most of people see the “mobile view” version with some random theme. Is it possible to fix it and make full version default?

Another thing is pictures on front page slider streching or narrowing according to some mobiles’ screens.

bless,
W.


#2

Hi,

As I remember, someone else had the same problem and it is plugin related. You are probably using some plugin which is serving mobile version of its own. Try to disable it, or if you don’t know which one is it, disable all additional plugins one by one, and try again.

Best Regards


#3

I just love Katori layout. I am wondering how to keep the welcome box on smaller displays. ie phone does not show welcome box.
nameoutreach.org


#4

@idahoster

Hello there,

You can try to apply custom css code below, but note that there will be no place for image, and intro text should be showing now:

@media only screen and (max-width: 499px) {
    .welcome {
        display: block;
    }
    .main-navigation {
        margin-top: 0;
        padding: 0;
    }
}

You can apply the code from child theme style.css file or with this plugin https://wordpress.org/plugins/simple-custom-css/

All the Best!


#5

Thank you Di

That worked to show text. I now need to center text only on page. I added text align and it works like a charm.

@media only screen and (max-width: 499px) {
.welcome {
display: block;
text-align: center;
}

.main-navigation {
	margin-top: 0;
	padding: 0;
}

}


#6

Now that I have mobile working it does not look that good on full page.
Is there any way to comment out the full page view only showing the text on mobile?


#7

You’re welcome,

Unfortunately there is no way to turn off full screen view because it is holder for the text inside. If there is something else, please try to explain, and I will try to help if possible.

All the Best!