Mobile menu does not open

Hello,
I really apreciate the Astrid-Theme very much because it is beautiful and easy to use. Unfortunately there seems to be an issue with the mobile menu. After usiing the mobile menu several times (clicking some links), it does not open anymore. In the Inspector of the browser the whole moile-menu-section seems to be missing then, so I can’t use a CSS-workaround. This problem appears not only with some websites I build but also with the demo version of Astrid and Astrid pro.
Is there a solution for this issue?

Many thank in advance,
Till Daniel Müller
PS: Sorry for my bad english :frowning:
PPS: This problem appeard on Firefox, I did not test other browsers yet

HI Daniel,

I am sorry to hear that you’ve run into an issue. I am happy to help out.

Can you share a link to your website here, so I can inspect it directly and help you in a better way?

Regards,
Kharis
aThemes Support

Hi Kharis,
thank You for Your reply. You can reproduce the described behavior with every website with Astrid theme. I just checked it with the demo version of Astrid Pro (https://demo.athemes.com/astrid/shop/) using Firefox on a Surface Pro 6 with Windows 10 or a Chiaomi Redmi 10 Smartphone with Android and Firefox. After navigating a bit on the website using the mobile menu to change between Home, Blog and Shop the menu stops working. The mainnav-section has the id ‘mainnav’ then, not ‘mainnav-mobi’. I can change the id manually to ‘mainnav-mobi’ and it works again.

Regards,
Daniel

HI Daniel,

I am sorry, I can’t get the issue.

Can you confirm whether this issue occurs only when the web browser’s inspector tool is being opened? Can you try refreshing your web browser and visit the demo in normal mode without inspector tool?

Regards,
Kharis
aThemes Support

Hi Kharis,
Yes, it occurs without inspector tools. I get it with Firefox, Microsoft Edge and Chrome, Safari, MII Browser on different computers and Smartphones. With Astrid lite version it occurs more often then with pro. I couldn’t find out yet by which exact circumstances it is triggered.
I get it by opening the theme’s demo version (https://demo.athemes.com/themes/?theme=Astrid), change to mobile view (if the used screen is too large for the mobile menu to show) and click three or four times the menu links.
Regards,
Daniel

Short update:
The issue occurs after uprading WordPress to version 5.6.1. I checked with an older website and it worked fine. After the upgrade I got the described issue.

Regards,
Daniel

HI Daniel,

I checked again, and still the same, that I can’t reproduce the issue. The mobile menu looks fine to me.

Can you confirm whether you’re running the latest versions of web browsers?

Regards,
Kharis
aThemes Support

Hi Kharis,
I tried it with different devices, different operating systems and different (fully updated) browsers. I even asked some friends and colleagues to reproduce the issue, always wih the same result, that the menu stops working after some clicks. For the websites using Astrid theme I solved this issue by surpressing the mobil menu completly and implementing my own mobile menu. I just can’t imagine that nobody else ran into this issue.
Regards,
Daniel