Mobile Devices Menu - Bug


#1

Hello all,

I really like the theme and would love to make everything fully functional to be able to use it.
A problem occurred when viewing the theme on mobile apps.

The links on the menu are not visible. Just when you press them, they become visible. Working they are. It seems something with colors must be messed up.
I googled and checked these forums.
I added these custom CSS lines with the plug in Custom-CSS:

@media only screen and (max-width: 60em) {
/* Make default menu color black /
#main-navigation li a {
color: #737373;
}
/
Add dotted border to bottom of menu */
#main-navigation ul {
border-bottom: 1px dotted #000;
}
}

But no success.

Screenshots:
iPhone:

iPad:

I cannot post a link since I don’t want my blog to be public yet. But Csaba, who assists me with another problem in topic:Firefox, Chrome bug sidebar, has gotten my link via email.

Do you have any suggestions?


#2

Hello there,

I think you’ve already made some changes to the background of the main menu. Please try to use the css code below to fix your issue:

@media only screen and (max-width: 60em){
  #main-navigation > .sf-menu > ul {
     background: #333;
  }
}

#3

Dear Awan,

Thanks for your assistance. I appreciate it a lot.
Unfortunately the CSS code you mentioned doesn’t make any difference to the code I mentioned in my first post (except the dotted line added of course). But I still cannot see the links of the menu, there are just white fields that I can click to open the page. But that’s not acceptable because people that don’t know the site don’t know what they are clicking :slight_smile:

Anyway, if I cannot make it work, I unfortunately cannot use this theme - although I would love to.


#4

Dear Awan,

I don’t know what I did, since I just put the code of yours in that didn’t work at the beginning. NOW, I can see the menu.
But I suddenly have now a problem with the sidebar, I don’t know if these are combined or not. Anyhow, this is resolved and I will start another topic, if I may.

Thanks again!


#5

Glad to hear that the css code is worked :slight_smile: