Mobile and Tablet Menu isn't Showing Up

I am using the “yoga” starter for this website. http://www.ignite-change.com/ Running Sydney ProVersion: 2.0.9

The menu and top logo show up on the desktop version but not the tablet or the phone. I have tried adding

    #mainnav-mobi{
        display: block !important;
        float: none;
    }
    #mainnav-mobi ul li {
        float: none;
        display: inline-block;
        padding: 0 14px;
    }
    #mainnav-mobi ul li a {
        position: relative;
        float: left;
        padding: 0;
    }

but that didn’t work. Please help

Same problem here. Tried reverting back to 1.74 and Wordpress 5.6.2 but no luck.

Hi @fireball,

I am sorry to hear about your issue. I am happy to help out.

As checked with my web browser’s inspector tool, it appears you have this CSS code enabled from Additional CSS.

    header#masthead {
        display: none !important;
    }

Those lines indeed hide the top header bar on mobile screen as it was inserted within 1024px maximum media query.

I’d request checking the Additional CSS under Dashboard > Appearance; and remove those lines if it present.

Then flush any cache that is applied with certain plugin before checking your site. You may also need to clear cache, history, and restart your web browser to ensure there is no cached pages to load.

Let me know your views.

Regards,
Kharis
aThemes Support

Hi @vonrutch,

Thank you for chiming in.

Can I ask you to share a link to your website here, so I can do direct inspection to find out the actual problem and suggest the exact solution?

Regards,
Kharis
aThemes Support

The site is www.onssonenbreugeltv.nl.

I also tried disabling all plugins and removing cache.

Hi,

Thank you for sharing the link.

You’re currently running different theme (that is Leto) and seems likely you’re not having trouble with the mobile menu. Am I correct?

Further adding, if you have any questions with Leto theme, feel free to raise topics on its own support channel at https://forums.athemes.com/c/leto/36. Please avoid asking multiple questions at once. Use one topic for one question instead.

Regards,
Kharis
aThemes Support

No, the link goes to this website:

https://onssonenbreugeltv.nl/

Hi,

As inspected, you’re currently running a child theme. Perhaps the header markup has been overwritten from it and broke the mobile menu.

Can you try switching to Sydney main theme?

Regards,
Kharis
aThemes Support