Missing Custom Fields


#1

Under the “Front End Display” Template and Archive tabs I have the following error codes:

Your theme’s template file for displaying Employee items is missing custom fields.
Visit this Employee
Resolve

The Employees archive of your theme is missing custom fields.
Visit the Employees archive

When I click “Resolve” a link pops up that says:

Toolset plugins let you design templates for single items (Employee pages), with all the fields that you need to display.
Learn about creating templates with Toolset

Do these errors need to be resolved in order for the site to properly function. If so, what do I need to do?


#2

Hi,

Please read the documentation: https://athemes.com/documentation/quill/ and from point 3 import the settings file ( the .xml file you can download from the “this XML file” link ) to types plugin, so that will setup your missing Custom Post Types.

Kind Regards,
Csaba


#3

Hi Csaba,

I imported the recommended XML file and the error codes under each of the service tabs are still there. Do you have any other suggestions?

Thanks!


#4

Is there an additional Toolset plugin that we need to purchase to fix the custom post types? The error is showing up under “Template” and “Archive”. When I go to click resolve the link takes me to the following page and it looks like an additional plugin needs to be purchased?


#5

Hi,

You don’t have to purchase it, you can install the Types Plugin from wp-admin -> Appearance -> Install Plugins and install “Types” plugin if you haven’t installed it already and import the settings file from the theme’s documentation using that plugin, in wp-admin -> Toolset -> Export / Import.

Kind Regards,
Csaba


#6

The configuration file needed for the Types plugin appears to be missing. The link in the documentation (https://athemes.com/download/settings-quill.xml) generates a “Page Not Found” error.


#8

Hi,

I have assigned this topic to the development team, so they can fix the types configuration file link.

Kind Regards,
Csaba