Metadata in single post disappears

Hello! I have a problem, when I am editing a simple blog post the metadata appears with the publication date. But when I disconnect from the site and look at it as a visitor it doesn’t show the date. Also no comments-link appears. I have tried everything! Is there any solution? My site is https://tinyurl.com/yxe72fq4

Thanks a lot

dcadva logged

sxoiodn visitor

Hi,

Thank you for contacting us. I am happy to help with your issues.

As checked with the web browser’s tool, I found this code, that may present in your website’s Additional CSS, hides the meta data shown on your screenshots.

    .single .post-cat, .single .posted-on {
        display: none;
    }

Can you please check it and let me know the purpose of that code? Perhaps I could make a little corrections with it.

Regards,
Kharis
aThemes Support

Ops! Thanks for answering! Perhaps, at some point a long time ago, I put in similar code at css custom. But I already deleted it. It is not currently showing up in my Custom Css. My custom css now show this:Right now the custom css is:

"You can add your own CSS here. Click the help icon above to find out more.

    .wpcf7 input,
    .wpcf7 textarea {
    width: 100%;
    }

    .wpcf7 label {
    display: block;
    }

    div.wpcf7 {
    max-width: 30em;
    margin-left: auto;
    margin-right: auto;
    }

    .single-services .page-wrap {
          padding: 0;
          width: 100%;
        }

        .single-services .content-area.col-md-9 {
          width: 100%;
        }

        .single-services #secondary {
          display: none;
        }

    .comment-meta a {display: none! important;}

    .aligncenter {
    text-align: center;
    display: block;
    }

    .page-id-750 .hentry .entry-header {
        display: none;
    }

    .page-id-82 .hentry .entry-header {
        display: none;
    }

    .page-id-30 .hentry .entry-header {
        display: none;
    }

    .page-id-32 .hentry .entry-header {
        display: none;
    }

    .page-id-34 .hentry .entry-header {
        display: none;
    }

    .page-id-1424 .hentry .entry-header {
        display: none;
    }

    .page-id-1849 .hentry .entry-header {
        display: none;
    }

    .page-id-36 #tpbr_topbar,
    .page-id-36 #masthead,
    .page-id-36 .header-clone,
    .page-id-36 #tpbr_topbar,
    .page-id-36 #masthead,
    .page-id-36 .header-clone {
        display: none;
    }

    .single-services .single-meta {
          display: none;
        }

    .single-employees .single-meta {
          display: none;
        }

    .meta-post {
         text-transform: uppercase;
    }

**Question: It may be fragment that you find is embedded in the sidney theme code ( functions, templates …) by me? How can I delete it?

    single .post-cat, .single .posted-on { display: none; }

Thanks a lot! I appreciate any answer!

Hi,

I checked your post and now the post date line is appearing like this.

Did you add some extra CSS code that resolve the problem? Or, do you still need help with it? Please let me know.

Regards,
Kharis
aThemes Support

Oh thanks! I had not had time to respond you. I have solved the problem because the code that you found was in the critical css that I inserted a few weeks ago. I have deleted the critical css rule and the problem is fixed. Thank you very much for your attention Kharis !!

1 Like

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support