Menu Stability


#1

Hello there,

My site is www.pieeyed.co.uk

When I go on any page my menu is at the top, but when I scroll down onto the page contents the menu goes very ‘jumpy’ - and i just wondered if there is something i have done wrong / can done to fix this?

Fantastic theme, thank you.

Jack


#2

Hi, menu have transition effect, it is normal (it changes size on scroll). You can maybe try disabling Stop the nav bar from being sticky? from Appearance > Customize > Menu.

Maybe you should try to explain me a bit what is going on and what is that you want to achieve?

I also suggest to hide footer from front page if it is going to stay like that (empty).


#3

Hi, thank you very much for getting back to me.

I don’t want the menu bar to always be at the top of the screen, I just want it to be at the top of the page. When I stopped the nav bar from being sticky, it was then always on screen?

My main issue is that when I scroll down the menu bar at the top is very ‘jumpy’ as you scroll down. its not a massive issue, but it would be good if it could be solved!

Also, i know this is a silly question but how do i remove the footer (i’m very new to this!)

Thanks


#4

Ok, don’t change menu setting, just apply custom css code below. This is nice plugin to have for that purpose.

This will enhance menu a bit:

.top-bar {
  height: 100%;
}

This will remove footer from front page:

.home.page footer#colophon {
    display: none;
}

So, apply both codes, and let me know if it is better.


#5

Brilliant. The footer has indeed gone without an issue.

The menu is still a little jumpy, but it is better than it was before, so thank you for that too. If there is anything else I can maybe try that would be good, but if not do not worry!

Thanks


#6

The menu will be without any transition effect if you set both paddings the same from Appearance > Customize > Menu. If that’s what you mean by jumpy.