Menu Anchors not pointing correctly on Mobile

Set the menu anchors and they work fine on desktop, but on mobile/tablet, the anchors just direct to the top of page where anchors are not specifically at the anchor locations? I’ve searched through the forums and couldn’t find anything on this.

Website is https://sidneymuseum.ca/

Hello there,

Try this solution:

https://wordpress.org/support/topic/problem-with-anchor-link-1/#post-7647135

Let me know how it helps.

Regards,
Kharis

I was a little hesistant to install an update that is not compatible with the last THREE major releases of Wordpress? Did it and inserted the code as you described…problem still there. Works fine on desktop, but not mobile. :thinking:

There should be no problem with that notice. The plugin should be normally working. If it doesn’t, please let me know.

Regards,
Kharis

Loaded the plug in and inserted code as instructed…still not working on mobile. :frowning:

This is so strange because everything else works perfectly. When I go to another page and click on a menu item that is anchored on the front page, it will not go to the anchor, just the top of the page. Anchors seem to be working on every other page? hmmmm

Hello there,

It looks like #current-exhibit element is hidden on mobile screen. Normally, it should be visible to avoid a ‘not-found’ scrolling. Please check your element’s settings and ensure no configuration that hides it.

Regards,
Kharis

Yaaaas! Success!! In the future I will make sure to check Responsive configs on all pages.

Thanks so much for the quick response and solving my problem. :slight_smile:

You’re welcome!

Glad to hear all resolved. Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis