Menu acting weird

Hello,

My menu with Solon theme was in line, and now it’s all links one under the other, the problem being that I didn’t touch anything, it happened overnight.
In mobile version the menu is displayed fully, it’s not just the fab bars to click anymore, and again, I didn’t touch anything.
Could it be a conflict with a recent Wordpress update?
I’ve tried several things but it doesn’t change anything.
Also, weirdly enough, there’s no menu anymore in the menu section in the admin panel, although my links are still showing on the front page (just not as they should be).
Can you please help me? I’m desperate -_-

Hello @mello,

Can you please provide a link to your website?

Kind Regards, Roman.

Hello,
Thank you for replying to me.
Actually I have removed this part from the header.php page:

<div class=“container”>
<button class=“menu-toggle btn”><i class=“fa fa-bars”></i></button>
<?php wp_nav_menu( array( ‘theme_location’ => ‘primary’ ) ); ?>
</div>

and changed my menu from primary menu to social menu, and it reappeared normally on computer, and on mobile my menu is displayed too but without the possibility to unfold (the little bars don’t show up anymore though so it doesn’t look that bad, as long as people have access to the menu).

That’s all I could find to fix it somehow.

My website is http://theunicorn.cloudbusting.fr

Thank you.

Oh, just noticed that my footer has disappeared too now…

Hello @mello,

I have just checked my local Solon install and it seems to work well with current WordPress version. You can make a full site backup and try to reinstall the theme.

Kind Regards, Roman.