Memory Limit


#1

Hi,
First of all, congrats for your Moesia Theme I really love !
I got big issues with my home page. I can’t load it anymore in the back office to set it.
I have this message : Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 337921 bytes)… etc…
I’ve found another post about the same subject : https://athemes.com/forums/topic/revolution-slider-8/

You replied : 'You need to increase your PHP memory limit. Unfortunately I have now way of helping with that but here’s an article that will help. If you can’t do it your host might be able to do it for you. '.

My host told me I have a already 96M memory limit - which is a lot - so the theme should work.
They told me maybe the theme is too heavy, or some of my plugins should be desactivated. Which I did. In fact, when I deactivate some plugins, I don’t have this message error anymore.

The problem is that I don’t have that much plugins installed : AddToAny Share Buttons, Black Studio TinyMCE, Contact Form 7, Page Builder, Really Simple CAPTCHA, SiteOrigin CSS, Types, Ultimate Responsive Image Slider, WP Video Lightbox

And I have to desactivate Duplicator, Google Analytics Dashboard, Polylang,
Redirection, Yoast SEO.
I really really need JP Widget Visibility, Polylang, Redirection, but there’s no way I can have all of them activated without getting the same error message.

Have you got any idea ?
Help !

Thank you very much !

Christophe


#2

PS : In addition of what I said, I got this problem only on the home page.
I can set any other pages.


#3

Hello Christophe,

Actually, you have quite feature-rich website (considering the plugins that you are using), so I think that it worth trying to increase the PHP memory limit to 128MB.

Here is the link to discussion of PHP memory limit, you can find many interesting opinions there:
https://premium.wpmudev.org/forums/topic/optimal-php-memory-size

I hope that it will help you to resolve your issue.

Best Regards, Roman.


#4

Hello Roman
Thanks for your quick reply. Unfortunately, it didn’t resolve anything.
I can’t increase the PHP memory limit to 128MB without being charged more from my hosting company… which I don’t want.
However

  • I don’t understand why my home page is the only one which is not working…
  • This website is hosted on a subfolder (mysite.com/2016). I already got the same theme on “mysite.com”. Do you think I should remove “mysite.com/2016” on a another domain name like mysite2016.com ? Could it help ?

Thanks for your help !

Best regards

Christophe


#5

I don’t think that changing domain will help you to resolve your issue.

I suggest you to replicate your issue on localhost and try if increasing PHP memory limit to 128MB helps.

Kind Regards, Roman.


#6

Thank you.
There might be some issues on your theme if we want to use it fully…

At one point I could have only the plugins needed by the theme and could activated no other plugins activated !!
AddToAny Share Buttons, Black Studio TinyMCE, Page Builder, Really Simple CAPTCHA, SiteOrigin CSS, Types

It was really weird. I added some “class” on some <span> in a visual editor on my home page, saved it, and then felt on the memory limit error message !

Looking around, I unchecked in PageBuilder setting
"Add Widget Class"
"Pack de Widgets Heritage (Legacy)
“Widgets recommandés”

And, so far, I don’t have the message anymore with some more plugins activated… (not all of them).

Food for thought…


#7

Thank you for the information.

I’m glad that it works for you now.

Kind Regards, Roman.