Media and Image Carousel display issues on Canvas Page Layout

I’m have an issue with the display of the image carousel and media carousel in Sydney Pro. If I use the Elementor Canvas as the Page Layout, it works in the editor, but only displays one image and won’t rotate on a preview/published page. Changing to any other Page Layout resolves the issue, but isn’t desirable for landing pages.

Any suggestions would be appreciated.

–John

In Editor:

Published Page:

Hello there,

This probably means the issue is from Elementor’s page layout. Canvas page template is owned by Elementor and you may want to consult to the support team of Elementor to confirm if there’s incomplete scripts loads or other possible issues.

Sydney Pro has “No header image - Wide” page template that might be working for you.

Regards,
Kharis
aThemes Support

Thanks for the reply. I checked with the Elementor team and they found a javascript error that appears to be coming from the Sydney template. I have attached their screenshot of the console output as well as my own.

I appreciate your help!

–John

From Elementor:

From my browser:

Thank you for getting back with extra details on code error. I’ll be checking on my test site about this; and will be back to you as soon as possible.

Regards,
Kharis
aThemes Support

Hello there,

I am sorry I didn’t get the same issue. Please check your Sydney Pro’s version. Are you running the latest version?

Regards,
Kharis
aThemes Support

Hi Kharis,

Here is my setup:

  • Sydney Pro 2.0.15
  • Managed wordpress on GoDaddy
  • Wordpress 5.3.2
  • PHP 7.2

The problem is definitely somewhere in the Sydney Pro theme. If I change to Twenty Twenty, the landing page loads as expected in preview and live.

I tried re-installing the Sydney Pro with the steps below, but the problem remains.

To re-install, I

  • downloaded a fresh zip file
  • changed to a default theme
  • deleted my instance of the Sydney Pro Theme
  • re-installed the Sydney Pro Theme
  • activated the new install of Sydney Pro
  • reloaded the page in multiple browsers with the same results.

The page with the problem is here.
http://kvi.152.myftpupload.com/2019-display-winter-2-in-market-services/

I also tried creating a new canvas page with nothing on it and when I preview or load the page, I get the same error. Based on that, the error isn’t from a specific widget or section on the page, but simply from trying to use the Elementor Canvas page template.

  • Create new page
  • Set the page template to Elementor Canvas
  • Give page a title “e”
  • Edit with Elementor
  • Preview
  • Load Developer tools and see error.

Is there a better way to make a full page landing page using Sydney Pro without using the Elementor Canvas Page Template? I tried the other included page templates, but none of them will give me a full page with no headers/menus.

FYI, I was able to resolve the issue by copying the main.min.js file from the free version of the Sydney theme to the Pro version.

Great!

Glad to know you got it resolved yourself.

There should be permanent fix for this. I will pass this to our development team take inspect and work on it.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support