Masonry Image Glitch

When I have the porfolio set to “full width - stretched” or “full width” the images display with white space on the right sides. I have all the featured images set to the same size with a 3:2 aspect ratio. How can I remove the space so that the images are seamless? Toggling the column padding option doesn’t fix it either.

Hello there,

Thank you for getting in touch.

Could you please post your URL here so I can have a look?

Regards,
Kharis

Hi!
It seems as though the images just needed time to render or something. I looked back today and the grid is working as intended.
Thanks for your quick response!

I spoke too soon! Reloaded the page and the glitch is back.

I haven’t published my website yet. Do you have an email where I can send my admin credentials for you to take a look? Thanks!

Hello there,

My email address: kharisblank at gmail dotcom

Regards,
Kharis

Hello there,

Thank you for the login credentials.

In order to fix the issue, could you please try to add the following CSS code through the Simple Custom CSS plugin?

#isotope-container{
  width: calc(100% + 2px);
  width: -webkit-calc(100% + 2px);
  width: -moz-calc(100% + 2px); 
}

Let me know how it goes. I’ll wait to hear back from you regarding your stats.

Warmest regards,
Kharis

Hi Kharis,

Unfortunately, that didn’t change anything on the site. Any other ideas?

Thanks,
Erin

Dear Erin,

Could you please try the following?

  • Clear your browser cache
  • Flush all caches in your site if you have cache plugin like W3 Total Cache being enabled
  • Try to open it in different browsers

If none of them gives any changes, could you please post a screenshot with some annotations here. I might not able to catch your objective clearly.

Warmest regards,
Kharis

Dear Kharis,

That seems to have done the trick! Sigh…as easy as clearing cache. Similar to the good old IT adage, “Have you turned it on?” I’ll try this first next time I have an image rendering problem.

Many thanks for your thorough assistance with this issue!

Best,
Erin

Dear Erin,

Glad to hear that!

You’re welcome. I’m happy to have an opportunity to assist you.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Warmest regards,
Kharis