Logo depending on language

Hi I am using polylang and I am trying to change the logo in Talon depending on French or English. I saw the solution for Sydney, but am having trouble with it on Talon, here is what I have in the wpml-config.xml file in /obc/wp-content/polylang

But I don’t get the strings translation. Any help would be great. Thanks!

Hello, please check this topic:

Don’t forget to replace theme_mods_sydney with theme_mods_talon.

Kind Regards, Roman.

Hi Roman

Yes, I tried that:

It does not add the string translation.

Thoughts?

Thanks

-Blair

I did not realize the code was stripped out. This is what I have:

wpml-config
admin-texts
key name='theme_mods_talon’
key name='site_logo’
key
admin-texts
wpml-config

Hello Blair, so is it working now?

Kind Regards, Roman.

Hello Roman

No it is not, sorry.

I am using a child theme (of course) and have tried talon (theme_mods_talon) and the child theme name folder (theme_mods_childfolder), neither work.

Thanks

-Blair

Can you please provide a link to your website?

Kind Regards, Roman.

Sure http://obc.wdlntch.com

Hello Blair, thank you for the link.

It looks like your child theme name is obc, so please try theme_mods_obc

Kind Regards, Roman.

Hi

Thanks for the suggestion. I have already tried that, same result.

-Bair

Okay Blair, you can also try to do it with parent theme.

Kind Regards, Roman.

Hi Roman.

I did that originally–and it did not work.

Unless you want me to try switching the site to using the parent them itself with the file as a test?

I’m not sure if that will work, the child theme has no customization other than changing the footer. But I will try that sure.

Thanks

-Blair

Blair, it looks like this issue requires close inspection, this goes beyond our support policy, unfortunately.

As an option, you can contact Codeable for this kind of service, or find a reputable freelancer on Upwork.

Kind Regards, Roman.

Hi

Thanks for the help. Just a note, I ended up getting this fixed myself. In case anyone else runs into this, I moved the wpml-config.xml file into the child theme root directory. Then changed the code to (I changed the < tags to ( so they would not be stripped out):

(wpml-config)
(admin-texts)
(key name=‘theme_mods_childthemefoldername’)
(key name=‘custom_logo’ /)
(/key)
(/admin-texts)
(/wpml-config)

Essentially the ‘site_logo’ needed to be custom_logo and the file location is incorrect, it needs to be placed in the child theme folder not a new polylang folder. I had tried custom_logo but not moving the file into the child theme folder.

Thanks again, I really appreciate your effort in trying to assist Roman.

-Blair

You are welcome Blair, and thanks for sharing that!

Kind Regards, Roman.