Log+Name not possible

When adding my logo to the frontpage I cannot see my company’s name anymore…
How Come?
Thank you in advance for your reply
Kind regards
Leticia

Hello Leticia,

It’s intentionally designed that way. If you wish to have logo and site name, you could edit the header.php file in the child theme mode.

We have a Sydney child theme already. It can be downloaded here.

Regards,
Kharis

Thank you Kharis
I am still learning how to do this.
Iam using the Child so I have to copy the header.php first in there
and that is in the functions.php I guess…
and then I think I have to change:

<?php if ( ! function_exists( ‘has_site_icon’ ) || ! has_site_icon() ) : ?>
<?php if ( get_theme_mod(‘site_favicon’) ) : ?>
<link rel=“shortcut icon” href="<?php echo esc_url(get_theme_mod(‘site_favicon’)); ?>" />
<?php endif; ?>
<?php endif; ?>

But I have no idea how to add padding or otherwise create the space I need.
Still learning, but themes are an extra hurdle it seems
Leticia

Hello there,

Try to change the following code block


<div class="col-md-4 col-sm-8 col-xs-12">
    <?php if ( get_theme_mod('site_logo') ) : ?>
				<a href="<?php echo esc_url( home_url( '/' ) ); ?>" title="<?php bloginfo('name'); ?>"><img class="site-logo" src="<?php echo esc_url(get_theme_mod('site_logo')); ?>" alt="<?php bloginfo('name'); ?>" /></a>
    <?php else : ?>
	<h1 class="site-title"><a href="<?php echo esc_url( home_url( '/' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a></h1>
	<h2 class="site-description"><?php bloginfo( 'description' ); ?></h2>	        
    <?php endif; ?>
</div>

with


<div class="col-md-4 col-sm-8 col-xs-12">
    <?php if ( get_theme_mod('site_logo') ) : ?>
				<a href="<?php echo esc_url( home_url( '/' ) ); ?>" title="<?php bloginfo('name'); ?>"><img class="site-logo" src="<?php echo esc_url(get_theme_mod('site_logo')); ?>" alt="<?php bloginfo('name'); ?>" /></a>
				<h1 class="site-title"><?php bloginfo( 'name' ); ?></h1>
		<?php else : ?>
	<h1 class="site-title"><a href="<?php echo esc_url( home_url( '/' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a></h1>
	<h2 class="site-description"><?php bloginfo( 'description' ); ?></h2>	        
    <?php endif; ?>
</div>

Regards,
Kharis

Hello Kharis,

After months of silence [was a bit discouraged…] I am happily back working on my website…
The header problem I circumvented with making a logo+companytext and then on the same line my menu items all in a blue header…

I did not do your last suggestion with changing those code blocks [did not understand it correctly then]. Now at least I have found the header.php…so still have the
<h2 class=“site-description”><?php bloginfo( ‘description’ ); ?></h2>
still in there…

Yet right now I am in trouble again with my header…
It shows fine [in blue] in wp-admin and in Chrome, but in a screenshot from my website [screenshotmachine.com] and p.e. also in Opera it shows as a black bar with the menu stacked [and also in black]
[Even on mobile devices it stays blue in Chrome]

So how do I go from here?
Thanks for your patience and help
Leticia

Dear Leticia,

Could you please try to apply the following CSS code through the Simple Custom CSS plugin or child theme’s style.css?

@media only screen and (max-width:1024px){
  .site-header {
    background-color: rgba(34,65,122,0.9);
  }
}

Regards,
Kharis

Kharis, I don’t see any Sydney Child Theme in the link you gave?

Dear Tony,

We updated our documentation page a couple of months ago. The Sydney child theme can be download here.

Regards,
Kharis

Hello Kharis,

Helas…
it remains the same, that is to say that if I start scrolling down it becomes blue, but for starters it is real black :frowning:
I cleared my cache in Opera to make sure your suggestion was taken up.
now I removed it from Simple Custom CSS as it did not make a difference…
What else could I do?

Regards
Leticia

Dear Leticia,

Please share the link to your site, so I can take a closer look.

Regards,
Kharis

Thank you Kharis:)

Hello Kharis,

It seems the problem has disappeared by itself :slight_smile:

Thanks for all your answers and patience.
It was a nice learning experience

Regards Leticia