Live View Editor does not work anymore

Apparently the Live View on the starting page to see directly the changes does not work anymore. It worked fine, did not change or add any plugins. On single sites the live view still works fine.

I think it has something to do with the additional code like adding the second button or changing the code in the top menu section, because the submenu did not appear in the same line like the prior menu and was not clickable. Used for that a code from the forum. https://athemes.com/forums/topic/a-problem-with-dropdown-menu-style/

Could you imagine, why it does not work anymore? At the moment, I make changes via the widget section of the theme in the back end of WP.

Thank you.

Hello Tom,

Did you update the theme? Few hours ago Astrid 1.10 became available here.

Please remember about importance of regular full site backups (files and database).

Kind Regards, Roman.

Even with 1.10 is the live editor on the startpage does not work. On all single sites it works fine.
I updated WP to 4.6 the day before yesterday. Did not have any effect on the live editor.

Hello Tom,

Can you please try to temporarily disable the second button code and see if it helps?

Kind Regards, Roman.

Hello Roman,
disabling the second button does not help, unfortunately.
I also deleted temporarily all other custom js and css, but that did not change anything. On single sites it works still fine. hmmm…

But another point: Did you change the widget options in the wp menu with the 1.10 release? I can not find the style options for each widget anymore. As the Live Editor does not work in my case, how can I now change the colours of each widget easily? Any idea?

Thanks again.

Hello Tom,

Can you please try to reinstall WordPress (just click Re-install Now button in Dashboard → Updates section) and see if it helps?

But I strongly recommend you to make a full site backup first.

Kind Regards, Roman.

Ok, I will give it a try.

Also please check these links, they might be helpful in your case:

https://wordpress.org/support/topic/live-preview-and-customizer-not-working?replies=16#post-7043880
http://wpexplorer-themes.com/total/docs/troubleshooting-customizer/

You can as well activate a default theme (like Twenty Sixteen) to see if it’s a theme issue.

Kind Regards, Roman.

Hello Roman,
me again :wink:

I tried everything covered in the links and some more things after a long search in the web, including changes of zlib and gzip compression settings, deactivating all plugins (did not change anything when all plugins were uninstalled), updating to PHP 7, reinstalling WP 4.6, deleting the second button again, and a lot more. Problem is still here.

The interesting part is - I have a multisite installation and my other themes work fine with live editor, same configuration except the theme. Even so the Single Pages of Astrid show me the live editor as it should be. Only the start page remains blank. I see on the left side the live editor and I can make changes, except the “Widget” Section which is empty, but I do not see the page itself.

I am wondering if some of the following things might have an influence on Astrid Start Page?

  • I had Intro installed before including the recommended plugins like “Types”. Could there be any interferences? Types and Wordpress Importer and the other plugins are deactivated.
  • The failure wp_get_sites is deprecated since version 4.6.0! Use get_sites() instead. is shown under Yoast Plugin, but only in the backend of multisite home directory not in the websites itself. Even though I do not have Yoast activated for the new site and I won’t do it. I activated it shortly to check if the live editor works with it enabled. It did not.

It would not be a really big issue to me and my workflow, if the button to style the widget sections directly in the backend has not been deleted with one of the last updates. Can I get it back somehow if we can not find a solution for the live editor?

Have a nice day nevertheless. And thanks once again.

BTW: I let the site live for you as long as this topic is not solved.

Hello Tom,

I have asked our Developer to take a look at your issue.

Let’s see what he says.

Kind Regards, Roman.

Thank you. I appreciate it.

One more thing came to my mind - could it be that the size of the logo has an impact on the live editor?

Hello Tom,

I don’t think that the size of the logo has an impact on the live editor, but you can try to edit/change it to make sure.

However, it looks like an old Multisite/Customize issue. Please check the link below, it looks like very similar problem.

https://wordpress.org/support/topic/multisite-domain-mapping-breaks-theme-preview-customize

Kind Regards, Roman.

P. S.
One more relevant link:
https://premium.wpmudev.org/forums/topic/multisite-customize-preview-broken

Hello Tom,

Did any of the solutions from that topics help you to resolve your issue?

Kind Regards, Roman.

Hi Roman,
here is the status quo. Now, it works fine again. Here is, how I did it, if somebody else finds this topic.

What I have done so far is explained in the prior posts until post 554813. The solutions for domain mapping issues and caching plugin issues in combination with multisites have been figured out by myself already months ago. I had the problem once before, deinstalled WP Super Cache and installed Comet Cache plus some custom lines of code for compression of my sites. I also turned off zlib.output compression. Worked perfect until some weeks ago I have started this thread. So - that was not the problem.

However - how did I bring back the live editor? Seriously, I do not exactly know. As my last attempt to get a solution I set up a new page in my multisite network and activated all the plugins and astrid theme the same way like I did on the website with the issues. I opened the new site and the live editor worked fine. So, next step, I went back to my “old” site with the missing live editor and I was really surprised that the live editor opened up. Some minutes before it did not work.

I guess there was anything in the database or somewhere else corrupted and that was overwritten with setting up the new website in my multisite network.

Thank you once again for your assistance and I hope, this issue will not come back. :wink:

You are welcome Tom,

I’m glad that everything is okay now, and thank you for such detailed explanation!

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.

Hi Roman,

the Live-Editor works on WP multisite (4.7) with domain-mapping, but google-maps of the sydney-widget will not shown. It works fine on the original subdomain, but it stops if I map the subdomain to a unique maindomain. Here is an example-page: https://concept-makler.info/ingo-huehnlein-details/

I don’t use the domain-mapping plugin, because since 4.5 it’s included in the wp-core you know!

Thanks in advance for your reply!

Sparen

Hello Sparen,

Please create a new topic for your issue in order to make it easier to help you.

Kind Regards, Roman.