Live editor and preview changes looks different from live site

I don’t know what I did. I am just launching my site and I went and published some posts. When I did that, my home page completely messed up. I had one image under the menu bar, and it is no longer there. Also, the post carousel disappeared.

When I go to live editor or preview changes tab on the home page editor, it looks great. I have logged out and checked the site, I have checked the site on my phone, I have cleared the cache, I have uninstalled and reinstalled the theme.

I have also clicked on Hide Feature Image from a Single post and added the following css code

.single.single-post .post-main-image {
    display: none;
}

but the feature images are still showing up at the top of my posts.

One other issue, I wanted to remove the metadata (author and date) from the post carousel and post list, I added the following css code, but they are still there.

.post-meta {
display: none;
}

Please help. My site is www.shebasjewels.com.

Hello,

It looks like you should set a static front page, please check this GreatMag documentation page:
https://docs.athemes.com/article/218-setting-a-static-front-page-greatmag

Please create a separate topic for each of your other issues to keep forum in good order and make it easier to help you.

Kind Regards, Roman.

If I set a static page will my posts automatically go to my homepage and to the post carousel?

Well, I don’t think that I can answer that because I don’t know your current configuration.

Please remember about importance of regular full site backups (files and database):
https://codex.wordpress.org/WordPress_Backups

Also you might want to check this tutorial:

Kind Regards, Roman.