Links to News items not working

Hi, I’m pretty new to WordPress, so I may have overlooked something simple. I am having a problem with my news posts, on both my front page and news page. The excerpts are not linking to the full news item, but instead are linking out to the top level website.

http://generationorbit.com/news/
http://generationorbit.com/home-clone/

(Note: our old website is still up so it leaves the WordPress and goes to an older html website)

Any help would be appreciated as we are trying to have this site up and functional as soon as possible. Thanks!

Hello there,

Thank you for reporting. I can’t reproduce the issue on my end. Maybe other plugin interferes it. Could you please try to temporarily deactivate the all non-required plugins one by one until you get it works properly?

Let me know how it goes. I’ll wait to hear back from you regarding your stats.

Regards,
Kharis

Thanks Kharis, I’ll give that a try. Were you able to see a full news item?

Let me try to explain again though because it is still doing it for me. If you are on the news page:
http://generationorbit.com/news/

And you click on any news item title, or any of the “recent posts” in the right hand column, everything links out to the top level “http://generationorbit.com/” which I do not want. I want the news item excerpts and all links to go to their respective news items.

Yes, I was able to see them.

I will wait to hear any update from you once you have done deactivating the all non-required plugins.

Regards,
Kharis

Ok, I tried deactivating plugins and refreshing to see if that did anything but no luck so far. I am also directly comparing another site I have made that uses the same theme where the news items are working fine to see if I can spot a difference in settings. Both sites have the same plugins activated.

http://blinkastro.com/news/ (working)
http://generationorbit.com/news/ (not working)

Kharis, what browser are you using?, I really have no idea how you are able to see the full news item! I’m using Chrome, but I checked in Firefox and IE and on multiple computers.

Got it fixed. I compared the two website settings back and forth and in the settings. In Settings> Permalinks there is a custom structure field that was empty and I simply had to copy and paste this:

/%postname%/

Awesome. it works now.