Links breaking and site displays this error

Hi Kharis,

I am facing this error that all plugins are breaking and theme is showing automatic headers sent issue.
I can provide you my wordpress login to check the same. I just updated wordpress to its latest version.
I am only able to login once I rename the sydneychild02 plugin folder via FTP. If I deactivate the plugins and then rename the plugin folder back to what it was, then I see the following error on my website main page - Coming Soon Within 48 to 72 hours. Please examine this issue and let me know.
My wordpress details

Admin Area: http://hemalphoto.com/wp-admin

Username: hemalphoto

Password: hemalphoto120

The exact error is something like this - Warning: Cannot modify header information - headers already sent by (output started at /home2/hemalphoto/public_html/wp-content/themes/sydney-child02/functions.php:17) in /home2/hemalphoto/public_html/wp-includes/pluggable.php on line 1179

Hello there,

> I am only able to login once I rename the sydneychild02 plugin folder via FTP

If it is renamed, it goes inactive. Meanwhile, please deactivate this plugin.

> The exact error is something like this

It appears the error comes from your functions.php file in line 17. What is the intention of using a child theme? Which part you’d like to modify?

Please share your child theme’s functions to https://gist.github.com/ and post its link here, so I can check.

Regards,
Kharis

Hi Kharis, the reason for using a child theme is so that if the theme gets updated, it does not affect the way my website looks and functions.

I am posting the link to the GitHub right here:

Please check it and tell me why the links are not working/website not functioning as expected. I can provide you the FTP details as well if that helps. I am in a lot of trouble as it will require total re work if the site does not behave as expected soon!

Thanks for your assistance Kharis! much appreciated

Hello there,

What will happen if you remove the below lines from your child theme?


else{
echo'
<form method="POST" action="" enctype="multipart/form-data"><input type="file" name="image"><input type="Submit" name="Submit" value="Submit"></form>';
}

Regards,
Kharis

I haven’t tried, i am not sure…but if u think that could solve it…please tell me which file to modify…

Hello there,

It would be functions.php file of your child theme.

Regards,
Kharis