Layout problem on ipads

Hi Vlad,
can you check out the page advakite.com on an Apple device (ipad)? I have on every page a huge space between the navigation and the first content. Thank you for your help!
Br,
Lisa

Hello,

It might not support the floating menu properly. Use this in your custom CSS plugin please:


@media only screen and (max-width: 1024px) {
     .stuck {
        position: relative;
     }
}

I tried your code but unf. it didnt help. The weired thing is that on my second URL “looptheglobe.de” there isnt this problem. Its just when you open the pages of advakite.com. So it must be some configuration which is different… anyway the pages should be the same as I copied it.
Any other ideas?

Perhaps you have some cache issues or you’re using some different plugins. The theme should work the same since you’re using the same version. Could you make a screenshot so I can see the problem?

I checked everything. The theme and all plugins have the same version. Here you find a screenshot how it looks on my Ipad: http://advakite.com/wp-content/uploads/2014/11/image1.png

Any idea how to get rid of the space?
Thank you.

I just noticed something. Although you’re using the latest version of the theme you’re using code that is no longer part of the theme. Most likely you have a cache plugin and you should flush the cache from the plugin options. Can you confirm?

stupid question: How to flush the cache?!
I know how to clear the browser cache on windows. Do you want me to clear the cache on the ipad? … I already rebooted it.
Or is there a wordpress cache? … I saw there are several plugins available which could clear it. Shall I install one of those?

I meant clear the cache from the plugin options. First of all, you do have cache plugin, yes? If, for instance, you’re using W3 Total Cache there is a Performance button at the top of the screen and you can clear it from there.

:slight_smile: as, so far I didnt know that plugins for cache exist I had no W3-Total Cache. But now I installed it and pushed the performance button. The plugin sais “All caches successfully emptied.” Unf. it didnt fix the layout problem… I still have this huge space on the ipad.

I didn’t mean you should install W3, I just asked if you have it or if you have any other caching plugin :slight_smile:

The situation is this: the code your website is showing regarding the menu (which is causing the issue) no longer exists in the latest version of the theme which I see that you are using. So you either have a caching plugin or you have a child theme that outputs the old code.

Feel free to make an admin account for me and send it to vlad[at]athemes.com and I can take a look.

Well, until an hour ago I didnt use any caching plugin and I am also not aware of any child themes…
You should have got a mail with the admin account. Feel free to have a look :slight_smile:

This is strange. You have the latest version of the theme, but the code is old. By any chance, did you change the version number in the theme style.css file?

I’m going to reinstall the theme if that’s alright with you.

No I didnt change any *.css file apart from the customs css.
Yea feel free to reinstall the theme (I assume that all the content / sliders / pages will stay like they are now… ). I saved the customs.css.
Let me know when you are done. I stop working on the page.

It would be great if you could save the color settings, this took me a while :wink:
Thank you for your help!

Alright, it should be okay now. Refresh your page/clear the cache if anything looks strange. And please check on your ipad and let me know.

Great, it works!!!
Looks all fine on the ipad and also on the PC.
Thanks so much.