Latest products section on frontpage BUG maybe..?


#1

I am not sure if it’s the update for the 4.4 that caused this issue, but this is what i see now for my latest products on the front page.

Preview image because i will not be keeping the page section while it’s like this, so my url will not be of much use: https://gyazo.com/bb3621ab9ccf71690ce6049739771d38


#2

It’s a rule in WooCommerce stylesheet wc.min.css, but it shouldn’t be.

wc.min.css is overriding your theme stylesheet because the css rule setting the width on the front page products is marked as !important. If you can get access to that file and locate the following line, just remove !important then your theme stylesheet will take over that element.

.woocommerce-page:not(.single) ul.products li.product,.woocommerce:not(.single) ul.products li.product {
width:30.8%!important,
}

Note: if you update your woocommerce it will likely happen again. Perhaps AThemes have a better way around this? Otherwise log a ticket with WooCommerce.


#3

Thank you for your time but it din’t work :slight_smile:


#4

That’s odd, do you have WP Super Cache enabled? If so you will need to disable it and refresh your page.


#5

I do not, I did a “factory reset” of my cpanel by deleting and restoring my files and reinstalled WP with only woocommerce and TheShop theme only (I did this to see if a pluggin broke my site or something) But i still get the same results.


#6

here maybe the link will help a little, I activated the section http://vectoruniverse.com/


#7

Great thanks Nina I will look at it now.


#8

Okay, so I removed the tag !important from line 1497 of wc.min.css and it displays as attached.

Is this what you were after?


#9

Yes absolutely, why din’t it work when i removed it?
I removed !important from the wc.min.css in my FTP manager before and it din’t change. So i re-uploaded the original wc.min.css file(Which is why you probably had it in the debug mode)

I couldn’t have removed the wrong one, theirs only one 30.8%!important value in the whole code.


#10

Never mind, now it worked lol go figure :stuck_out_tongue: Thank you so much for your help !


#11

Yay! Happy for you. Document what you did for when there is an update as you will need to do it again :slight_smile:


#12

Diffidently haha I will save this conversation just in case :stuck_out_tongue:


#13

This helped me too! Thank you Robin and NinaQc for posting.


#14

Nice on :slight_smile: Glad to help


#15

Hi, i would like to understand one thing

woocommerce latest version v 2.4.12 + TheShop v 1.0 no issue

woocommerce latest version v 2.4.12 + TheShop latest version v 1.03 - we are having this issue.

maybe issue is with the theme and it has to be reviewed so that it does not appear again with theme update.


#16

hi your solution is giving new issue on the shop page. Any other solution.


#17

Fair call - I’ll dig up the previous version files and try identify the issue if possible, otherwise I would highly recommend purchasing the premium template from Athemes and request support.

What was the new issue?


#18

The add to cart button get a little dissociated from the product section which is smaller if we remove important


#19

Great do you have a url I can see?


#20

hi

no url, i working on local

i found where i messed up. Instead of removing !important , i removed only important. It’s working fine now. thanks a lot.